LimeSDR-PCIe GW flashing issue via JTAG


I am trying to update LimeSDR-PCIe FPGA GW via JTAG. I have USB blaster from terasic. I am following the guide at this link

I have cloned the GW from

I compiled the code and generated the .jic file after placing the Xillybus files in relevant folders.

The programming stucks at 21% with an error message " Flash loader IP not loaded on device 1"

I am using Quartus Prime 15.1.2 Build 193 Lite edition on Windows 10 host system.

Can anyone help me with this issue. Thanks


most likely you did not marked both check-boxes near “Program/configure” after adding .jic file.

  1. Did you applied settings as shown in Figure 10 in mentioned user guide?
  2. Have you tried “Auto detect” in programmer to check JTAG chain?
  3. Have you tried programming .sof file?
  4. Post a screenshot of your Quartus programmer window with attached .jic

Hi @VytautasB,

2. Yes, I get the following message

  1. Yes that was successful. But I think I have to flash it every time I power cycle the board.

  2. Here

Failure Message

  1. All the FPGA LEDs are ON, does this indicate something? Also after flashing the .sof file the indication LEDs are solid RED.
  1. Is it LimeSDR-PCIe v1.3 board version?

  2. Can you post screen after “Auto detect” and pressing “Yes”?

  3. After successful .sof file programming you should see red/green color blinking on one of the two panel LEDs (Marked LED1 in Figure. 2

  1. Yes v1.3

  2. The following is displayed after clicking on Auto Detect

  3. I see solid RED Leds only after flashing the .sof file.
    First I tried to flash using LimeGUI the process got interrupted in between and the board is like that solid RED LEDs and does not show up in lspci. I thought to flash using JTAG to solve it. But I get this Flash loader issue when using .jic file. I cloned the GW repo and simply compiled it with no changes at all, except that I generated the xillybus ip core files.

Any idea what else can be done to bring up this board?

@Zack @andrewback Any idea what could be wrong here?

If you get solid RED light on both LED and if you did not applied any mods for the board this indicates that .sof file is programmed incorrectly or there are some problem with the board itself.

  1. Have you tested your Terrasic programming cable with other devices?
  2. Please use board directly inserted into PCIe slot, do not use any PCIe extension cables.
  3. Can you try this.sof programming file, just to make sure that we have correct one? This file is compiled and tested on LimeSDR-PCIe v1.3 board from Github master branch, there will be no Xilybus core and no PCIe connection but you should see blinking RED/GREEN light on one of the two LED fitted on the edge of the board.
  4. You could monitor FPGA configuration status pins before/during/after JTAG configuration if you have oscilloscope and post result for me. You can probe them on R63, R64, R66 resistors.

Here you can find mentioned resistors

And schematic fragment

Hi @VytautasB,

  1. I have two LimeSDR-PCIe board. I tried flashing the .jic file on the other one and it was successful. So this indicates the Terrasic blaster is working fine.
  2. The board is directly inserted into PCIe slot of the motherboard as shown above in the picture.
  3. I used your file to program. The programmer in Quartus say the operation was successful but the LED is still solid RED.
  4. I do not have an oscilloscope, any other method? Lets say there is something wrong with the signals what can be done next?
    20200424_113826 20200424_113841