Lime PCIe issue

I have a PCIe Lime that I’m trying to bring up, and I’m having some difficulty.

I’ve defined and downloaded the Xillybus core per the user guide, and successfully compiled it with the rest of the FPGA. I programmed the onboard configuration device using the JIC file generated by the Altera tools.

But I don’t see the SDR. LimeUtil --find locates nothing, and when I do an ‘lspci’ (Ubuntu) I see no difference when the board is plugged in or not.

Has anyone gotten through the procedure before? Is there something I’m missing?

@zack, thoughts?

Bit of info: before programming, FPGA LED1 was off and LED2 was flashing red/green.
After JICing the board LED1 was green and LED2 is off.

Hello @Zero,

How do you program JIC file? Do you use another computer to upload it or the same one, where the board is plugged in?

I used a separate machine. The Lime PCIe is plugged into a desktop machine I’m trying to bring up as a development system. The programmer was plugged into my notebook, which was running a Win10 VM with Quartus 15.1.2-193 installed (same version as was used for FPGA development).

I used a Terasic version of the Altera USB blaster hanging off the notebook.

I’m quite familiar with the FPGA tools, and it’s clear that the programming operation worked. Only question is why the PCIe interface doesn’t seem to be present.

Should I be able to see it with an ‘lspci’?

Hi @Zero,

OK, I see.

Yes. The output should be something like this:

01:00.0 Unassigned class [ff00]: Altera Corporation Device ebeb (rev 01)

When ls /dev, you should see this:


What is your board version?

Looks like version 1.3 (number is over near the 12V fan connector).

I’m working with the FPGA source currently on GitHub.

What about lspci and ls /dev?

Hi @Zero,

By the way, you should receive a distribution package together with the board. How it behaves when you upload compiled gateware from distribution package?

I received the package, but for the life of me I don’t seem to be able to find it.

I remember that there was a USB stick - I noted that, and put the package ‘somewhere safe’ where it will no doubt turn up when I no longer need it.

Any chance I can grab an image of what was on the stick?

OK, I tried the stock JIC - substantially the same behavior.

I say substantially because the LEDs behave differently - with my custom load the red/green blinker went out and a solid green LED came on. With the stock load the red/green blinker did not stop.

Altera programmer reported success putting in the JIC, and I did a verify. But I see nothing when I do an lspci, ditto in /dev.

On the off chance there was a JIC problem I brought the PC up into the bios screen, then loaded the SOF file and completed the boot process. Same behavior as with the JIC.

I’m going to try the board in a different PC today; I’ll report back on the results.

The board enumerates in a different PC. I have a bit of non-Lime related debug to do.

Thanks, everyone

Update: I still have an issue, but have seen some behavior that might offer a clue.

The motherboard I’m having trouble with is a new-ish MSI MS-7A72. On the chance that it was a BIOS issue I downloaded and flashed the latest version (currently E7A72IMS.160, dated 7/11/2017).

That did not fix the problem. But the system seemed otherwise flaky after the update, so I decided to clear the BIOS NOVRAM using the battery jumper on the PCB.

The first boot after resetting the NOVRAM I could see the PCIe Lime board. But on subsequent boots it was no longer visible. This behavior is quite repeatable.

Given this clue I was all over the BIOS settings, but have not yet come up with any combination that lets me see the board. The only way I can get it to work is by resetting NOVRAM.

Does this suggest anything to anyone?