Solid RED LED on LimSDR-PCIe


I tried to FLASH GW to my LimeSDR-PCIe board using LimeSuite. After power cycling it both the LEDs on the board are solid RED. Also I am unable to see the device when using lspci and even in LimeSuite connections tab. What could be the issue? Do I have to reflash it via JTAG?

@Zack @andrewback Please help !

Sometimes both LEDs starts flashing RED and sometimes the top LED is solid RED while the bottom one is OFF


May have something to do with the length of your pcie extenders. Might not be supplying enough current. What happens directly in the slot?

@ultrajv its the same. Actually I was trying to flash updated GW using LimeSuite GUI. It got interrupted and since then its like this. I tried to flash it using JTAG but I run into an error "Flash Loader IP not loaded on device 1 I am following the guide here:

Even flashing the .sof file instead of .jic file gives the same result. Any idea what could be wrong?

Does your pcie slot match the timing and voltage of the card? pcie has various specs. Have you tried another machine?

I don think so that should be an issue. I have two of PCIe v1.3 boards the other one is working perfectly fine. The issue is with flasing the GW. The .sof file goes through but not the .jic file on this board. On the other one flashing both the files works fine. I am not sure how to debug the cause of problem.