LimeSDR Mini on Mac: brew install limesuite failed to download dependencies

Trying to run LimeUtil --update and getting this error:

sh: wget: command not foundwnloading: LimeSDR-Mini_HW_1.2_r1.30.rpd
Failed: wget --output-document=

Programming update failed!

I went to look for dependencies in ~/.local/share/LimeSuite/images/ and found
% ls -l
total 0

I’ve tried reinstalling limesuite a few times, but this directory is never populated. Any ideas for how to get the .rpd file downloaded?

You can download the firmware and gateware that corresponds to the last release from:

However, it looks like there is a problem with your install and as I’m not a Mac user, I couldn’t say whether this is local to your machine or an issue with Homebrew, but fundamentally it would seem that this has not installed wget on your system and that being a dependency.

can you elaborate on the consequences of not having wget installed? i was able to download the firmware and gateware and LimeUtil --update seems to be working now. Thanks for the link.

wget is a command line application for downloading things like say a single firmware file from a website, or an entire website or multiple websites. In this particular case wget not being installed meant that “LimeUtil --update” tried to run it and failed, so it could not download the firmware. So then you needed to manually download the firmware and gateware files with a webbrowser and place them in the correct directory where LimeUtil expected to find them and then it ran as expected.