LimeSDR-Mini not found with LMS_GetDeviceList()


First off, I’m using Windows 7 64bit. I’m sorry, I’m not an experienced Linux user. I’d really like to stick to Windows for now at least.

My LimeSDR-Mini works well with Lime Suite, and several of the popular SDR packages. I’ve got it to transmit from my PC microphone but none of the packages that I’ve tried (and work) allow me to transmit an IQ file. LimePlayer looks like what I need. I could not find a Windows executable to download, so downloaded the Windows source and, after some faff (I’m using MVS2010), I got it to build using a Windows LimeSuite.dll and LimeSuite.lib downloaded from a link off this forum. As an aside: the versions of these files that installed with PothosSDR did not allow the linker to resolve the LMS library calls.

When I run my build, it fails at the first hurdle: ‘device_count = LMS_GetDeviceList(NULL)’ returns a value of 0.

II’d be very grateful for some help as I’m a bit stumped about where to go from here.

The answer to the above problem was to find a particular version of LimeSuite.dll - which I found in the installed (Program Files) area of a downloaded SDR program - CubicSDR. With this my code has been able to communicate with my LimeSDR-Mini. However, the LimeSuite.dll files which get posted on GitHub (e.g. here: )don’t work with my code. I do not know why and have no idea how to find out other than to ask here. I can see that the GitHub LimeSuite.dlls are much smaller in size than the one that works with my code. I tried to build LimeSuite for myself on Windows and ran into masses of problems. Can anyone offer a possible explanation of the difference between the LimeSuite.dll that works with my code and the ones posted on GitHub? Whilst the dll I have works ok, it’s built from an older version of LimeSuite and I would really like to be using the latest to get the benefit of all the fixes.

@Garmus may be able to advise.