LimeSDR Mini Fails LimeQuickTest on Mac

I have been fighting for months trying to get my LimeSDR Mini working on my Macbook Air. I have tried several software packages and nothing works. At this point, I’m concerned that my board doesn’t work. I’ve run the LimeQuickTest several times, and it fails consistently. Is there a way to determine if the board is bad? If it is bad, what can I do? (The output of the quick test is below.)

Thanks,

Darren

[ TESTING STARTED ]
->Start time: Tue Apr 27 18:28:31 2021
->LimeSuite version: 20.10.0-ga45e482d

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D587FCD7EA088, HW=3, GW=1.30
Serial Number: 1D587FCD7EA088
Chip temperature: 30 C

[ Clock Network Test ]
->REF clock test
Test results: 40822; 54019; 1680 - PASSED
->VCTCXO test
Results : 6711010 (min); 6711164 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 13 0A 15 13 0A 15 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-36.5 dBFS, 5.00 MHz) - FAILED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-45.5 dBFS, 5.00 MHz) - FAILED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 3.32 seconds

The loopback test values don’t look great.

@Zack, anything to suggest?