LimeSDR mini 2 and GNUradio - newbie question

I am the new happy owner of LimeSDR mini 2 board? Could somebody send me a link to some tutorial about where to find and how to install and configure the plugin for GNUradio to use LimeSDR mini2 as source and/or sink?

The only thing I found is the Soapy LimeSDR sink and source but it says:

self.soapy_limesdr_source_0 = soapy.source(dev, “fc32”, 1, ‘’,
RuntimeError: Failed to make connection with ‘’

Thanks for any help


Hi Jakub,

You can find gr-limesdr blocks here:

They haven’t been updated in a little while, so you’ll likely need to use an older GNU Radio release until we update them to the current series. That said, just spotted some PRs we need to review and merge, so you could try and build from one of those trees in the meantime.

Also make sure that you build Lime Suite from source and install this first. For the time being you’ll need to build from git master also. A new release should be coming soon.


1 Like

I tried to make the completely new installation:

  • Ubuntu 22.04 + all updates
  • LimeSuite (master) build from github source
  • GNURadio 3.10 (installed from Ubuntu package)
  • gr-limesdr (gr-3.10) build from github source

It seems that all is working properly (LimeQuickTest passed and LimeSDR Source is evidently communicating with the board, messages in GNURadio OK and LED on the board blinks red when communicating).
But there is no data stream on the LimeSDR source output (I tried just to tune RF frequency to the strong local FM radio and send output to the Waterfall sink).

Any ideas where could be the problem?

Hi @serych , I would like to try the same thing with my limesdr mini (not 2.0) and GNUradio (using gnuradio and Ubuntu 22.04). Did you manage to get it to work properly?

P.S. I’m a newbie and still unsure exactly what steps I need to follow to get the limesdr to work with gnuradio so any guidance or tutorial would be appreciated- this is the closest tutorial I could find (for Ubuntu 20.04 and gnuradio 3.8.1): LimeSDR setup with GNURadio, gr-limesdr and GQRX on Ubuntu-20.04 | by Dr.Signal | InfoSec Write-ups. Also I noticed that there is a new release for limesuite for 22.04 so can I use PPA instead of building from source?

I installed gnuradio and soapysdr and limesuite without compiling from source, and while it recognises the limesdr mini v2, I’m not sure I get proper signal power levels when compared with LimeSDR-USB with the same flowgraph. I had instelled on OSX with homebrew, and I guess installing from source is going to be a PITA.

Has there been any progress on this? I am in the same boat, I have lime suit built and installed with all tests passing in LimeQuickTest with my new mini v2.

Just built gnuradio 3.8 from source but it is apparently not finding gr-limesdr as an input option.

Is there an authoritative guide to making this thing work in 2024 in even if I have to have to start from scratch?

If you have gr-limesdr installed, but gnuradio is not finding it - it is likely that they were installed using two different versions of python. gnuradio 3.8 is fairly old and it is going out of use. What OS are you using ?

I was using Ubuntu MATE. After more experimenting I have things almost working with gnuradio

Current state of my problem is that I can TX with the limeSDR block, but cannot RX with the limeSDR block. Only the soapySDR block will RX. RX also works in gqrx.

Coming from rtl-sdr I’m not sure I know enough yet what questions I need to be asking.

With the limeSDR source block, make sure that the correct antenna is selected - some programs default to no antenna.

Thanks. I have messed with the antenna port setting without any luck so far. For the most simple test I used the LimeSDR block as a source and a file as a sink, grc will run without presenting any errors, but I end up with an empty file. If I replace the LimeSDR block with a Soapy block it will write data to the file.

I’m wondering if this is related to the fact that with LimeSDR Mini 2 you must enable Tx even for Rx-only applications, due to the way that clocking is implemented in the ECP5. Can you try adding both source and sink blocks to your flowgraph to see if this makes any difference.

Only the soapySDR block will RX. RX also works in gqrx.

OK, so that would seem to possibly disprove the above, unless these are enabling Tx even when it’s not used. In any case, still worth testing.

Tagging @zack and @ricardas.

1 Like

I was going to rebuild the latest limeSuite and gr-limesdr from source, but

builds with GNURadio-3.7 not with GNURadio-3.10.

There are branches for everything up to gr-3.11, but unclear if any are usable.

I’ll give adding a TX block to my RX flowgraph next weekend and see what happens.

RX does work in gnuradio, if the transmit is running. You do not need to do that with the soapy routines - it looks like limesuite needs a little work.

Soapy still uses Lime Suite, via the SoapyLMS7 module, so I’m guessing that Soapy must set up both transmit and receive streams regardless. That said, I have asked whether we can have Lime Suite automatically enable Tx on LimeSDR Mini 2, even when only Rx has been set up via the API.

Confirmed. Adding a TX block connected to a Null Source got my RX working.

1 Like

After reading your response, I’ve finally managed to get a GNU Radio Flow graph working with my Lime SDR!
If you could shed some more light on why this works, and what docs you read to come to this conclusion, I would really appreciate it :slight_smile:


  • Lime Suite GUI: Version 22.09.0-ge829d3ed Build Date 2024-01-17
  • GNU Radio: Version (Python 3.10.12)
  • OS: DragonOS FocalX (22.04)


  • Laptop: ASUS G512L
  • SDR: LimeSDR-Mini_v2 FW:10 HW:7 Protocol:1 GW:2.6 Ref Clk: 40.00 MHz

I’m not sure why it works, sorry ¯_(ツ)_/¯

I just tried it because of the suggestions in the post by @andrewback