Help Installing GNU Radio + GQRX w/ LimeSDR Mini + Ubuntu 18.04

I have installed the Limesuite, and I am able to connect to the board and calibrate it. I can run SoapySDRUtil --probe and can see my device.

When I try to run GNU Radio and GQRX, I get the same issue in the console. I have tried installation setup and setting for both programs that I could find on this forum and nothing has worked.

GNU Radio


Both cases have a “SoapySDR::Device::make() no match” error and I can’t find anything on this forum or on Google.

Help please? I got the LimeSDR Mini for Christmas and it has been a huge headache trying to get this running.

With GNU Radio you would likely be better off using the gr-limesdr blocks instead of gr-osmosdr, as they provide a more direct route and expose more of the hardware capabilities.

Example flowgraphs are also included.

Thank you. I installed gr-limesdr and I have been able to run the example flowgraphs.

Do you need to calibrate the board with Limesuit before running GNU Radio or is there a way to auto-calibrate it in GNU Radio?

1 Like

I don’t think it would help if you calibrated with LimeSuiteGUI first, since gr-limesdr would then apply its own new settings. @Zack, how is calibration handled with GNU Radio?