Having trouble with limesdr DVB-T example

I am using the example grc file found with on the page https://wiki.myriadrf.org/Gr-limesdr_Plugin_for_GNURadio#Digital_Video_Broadcast_DVB-T_transmitter_example and when I execute the flow graph, the limesdr mini that I am using outputs nothing and the GUI that comes up doesn’t do anything either. (I am assuming the dots are supposed to flash as data is transmitted…)

I have tried tuning to the set frequency with an RTL stick and VLC to attempt to receive the video feed, but it really does appear that there isn’t anything being transmitted with this example.

I have verified that the board itself works via LimeQuickTest and the use of a FM transmitter flowgraph that produced audio in a nearby radio, albeit somewhat distorted.

I picked up the limesdr mini in hopes to use it as the core of an ATV station, but being really new to all this, GNU Radio and the behavior of the sdr have me a bit lost as to what is going on here.

OS: Linux Mint (based on Ubuntu 18.04)
SDR: LimeSDR Mini
Software: GNU Radio 3.7.11
GRC: https://pastebin.com/dpVUEaKx

Are you running in a virtual machine? That can cause trouble. If you have access to WIndows, there is Express DVB Transmitter.


Heres a guide but again its Windows based. Ive used the guide and it works fine.


UPDATE: I tried the express software on windows and unless I’m missing something (or my receiver usb stick is broken) it is not working.

I am running Linux on bare metal. I did however figure out something that could be the root of the issue and its present in Windows as well, the “USB 3 - SS” ports on this machine keep coming up as USB 2 ports and when they do, they max out at 3Mbps for some reason.

I have a laptop that I can try this on and see if things act right there. I will post back when I have time to test things with the laptop. For now, the desktop seems to have issues.

USB 3 might need a few changes to Windows To work fully. It needs to be set on high power and fast start needs to be turned off.

Not unusual for certain USB 3.0 chipsets to prove problematic and so worth trying other computers if possible. Also if using a cable, try alternatives.