LimeSDR mini, no joy


#1

So, let me start off with I am sorry this post is so long.

I am one of those people who received their LimeSDR Mini from CrowdSupply and cannot make it work on Ubuntu. GQRX seemed to be working in windows 8.1 but no joy on my primary use case – and I have tried like hell.

I started by building everything from source on raspberry pi 3b but i had no luck with that. There were various issues where entirely different driver names would show up as compared to the packages so I have taken a step back. I am now trying to do a vanilla install on Intel using an Asus Ubox.

I have Ubuntu 16.04 LTS installed on a 64 bit celeron cpu. This should be easy to get going right? I have deleted all my builds from /usr/local and I followed the instructions from https://wiki.myriadrf.org/Lime_Suite – At this point, the base software looks good. LimeSDUtil is responsive and says all the right things. LimeSuiteGUI is able to identify the radio, connect to it, pull sensor data, booya. That works.

Next, I installed gqrx basically with these instructions https://launchpad.net/~gqrx/+archive/ubuntu/gqrx-sdr/

and since I dont like to redo the same bits of work I integrated the two sets of instructions into one script that looks like this:

https://launchpad.net/~gqrx/+archive/ubuntu/gqrx-sdr/

I installed it like this:

root@radiohead:/home/jason# cat make-myriadrf-install.sh
#!/bin/bash

sudo add-apt-repository -y ppa:myriadrf/drivers &&
sudo add-apt-repository -y ppa:bladerf/bladerf &&
sudo add-apt-repository -y ppa:myriadrf/drivers &&
sudo add-apt-repository -y ppa:myriadrf/gnuradio &&
sudo add-apt-repository -y ppa:gqrx/gqrx-sdr &&
sudo apt-get update && \

sudo apt-get install -y limesuite liblimesuite-dev limesuite-udev limesuite-images &&
sudo apt-get install -y soapysdr soapysdr-module-lms7 && \

echo ==== testing phase ====

echo " == testing limeutil =="
LimeUtil --info

echo " == testing SoapySDRUtil --info =="
SoapySDRUtil --info

echo " == testing SoapySDRUtil with driver=lime =="
SoapySDRUtil --find=“driver=lime” | tee /tmp/outfile
count=grep "LimeSDR Mini" /tmp/outfile |wc -l

if [ $count -ne 2 ]; then
echo SoapySDRUtil --find=“driver=lime” FAILED.
echo not install gqrx-sdr
else
echo === SoapSDRUtil SUCCESS ===
sudo apt-get install gqrx-sdr
fi

A re-run of the installation script output looks like this: https://pastebin.com/HWuiZKK4

Okay, here is where the bad news comes in…

GRQX complains about setting frequencies. I used to have a whole other set frequency related errors and then I followed some post about calibrating the radio. Some of which worked and bits of the instructions threw errors… Frankly, that part was totally over my head. Here is what I have now when starting gqrx

https://pastebin.com/3EGNfymM

Loading configuration from: “/root/.config/gqrx/default.conf”
Configuration file: “/root/.config/gqrx/default.conf”
gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp plutosdr miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya
[INFO] Make connection: ‘LimeSDR Mini [USB 2.0] 1D3AC9CAF1F71E’
[INFO] Device name: LimeSDR-mini
[INFO] Reference: 40 MHz
[INFO] Init LMS7002M(0)
[INFO] Ver=7, Rev=1, Mask=1
[INFO] LMS7002M calibration values caching Disable
CGEN: Freq=80 MHz, VCO=2.56 GHz, INT=63, FRAC=0, DIV_OUTCH_CGEN=15
CGEN: Freq=61.44 MHz, VCO=2.4576 GHz, INT=60, FRAC=461373, DIV_OUTCH_CGEN=19
CGEN: Freq=61.44 MHz, VCO=2.4576 GHz, INT=60, FRAC=461373, DIV_OUTCH_CGEN=19
CGEN: Freq=80 MHz, VCO=2.56 GHz, INT=63, FRAC=0, DIV_OUTCH_CGEN=15
[ERROR] SetFrequencyCGEN(80 MHz) failed:
INT: 63 FRAC: 0 DIV_OUTCH_CGEN: 15
VCO: 2560 MHz RefClk: 40 MHz
TuneVCO(CGEN) - VCO too low
M=156, N=3, Fvco=1040.000 MHz
M=156, N=3, Fvco=1040.000 MHz
MCU programming : 16384/16384
MCU Programming finished, 3126 ms
[ERROR] MCU working too long 4
[ERROR] setBandwidth(Rx, 0, 30 MHz) Failed - SetFrequencyCGEN(80 MHz) failed:
INT: 63 FRAC: 0 DIV_OUTCH_CGEN: 15
VCO: 2560 MHz RefClk: 40 MHz
TuneVCO(CGEN) - VCO too low

FATAL: SetFrequencyCGEN(80 MHz) failed:
INT: 63 FRAC: 0 DIV_OUTCH_CGEN: 15
VCO: 2560 MHz RefClk: 40 MHz
TuneVCO(CGEN) - VCO too low

Trying to fill up 1 missing channel(s) with null source(s).
This is being done to prevent the application from crashing
due to gnuradio bug #528.

So as far as I can tell, GRQX is as deaf as my 92 year old great aunt. When I start the DSP I get an endless stream of “No audio FFT data” sent to stderr

Also, on the input Controls tab, there are no antenna options. I recall there being four or five options when it ran in wintel.

I am pretty sure my installation of the repo packages is solid. Is there some tuning that needs to happen to get the linkage in-line? Any ideas?


#2

I have successfully used LimeSDR-Mini on a raspberry pi 3.

Here’s my image:
https://pan.baidu.com/s/17ntMb51EZPh9OKa0FjdXtw
password:d7l1

If you want to use raspbian, then you need to compile a lot of stuffs.
If you install ubuntu 16.04 on raspberry pi, then you can use apt.


#3

Thanks for the image offer, I was unable to authenticate.

My ultimate goal is start using the Osmo GSM and LTE software which isnt packaged, as far as I can tell. However, before I can run, I need to be able to walk so getting the basics to work is essential. I want to build a reproducible process but there is some element of this that has thus far escaped me – even getting the PPA to work is problematic.

j.


#4

The Ubuntu PPA has been updated 8 hours ago with LimeSuite 18.03, which I think is required for the LimeSDR Mini. So please update the soapysdr-module-lms7 which should bring in liblimesuite18.03. In addition, you also need liblimesuite-udev; apparently it is not installed automatically.

When done, plug in your LimeSDR Mini and run “gqrx -r” to reset the configuration. The config dialog pops up. Select LimeSDR Mini but modify the device string to:

soapy=0,driver=lime

(I don’t know why the auto-detected device string does not work, but this tip has already been posted in many thread about this same topic)

Gqrx should now hear much better than your 92 year old aunt :wink:

If you see errors in the terminal from the backend, there is no reason to continue as gqrx will most likely not receive and samples from the device.

Alex


#5

First, thank you very much for the reply. It was very helpful. I have been quite clear on driver=lime,soapy=0 and that was never a problem.

I do have some questions though…

Is this the correct driver list?
Supported connections:

  • FT601
  • FX3
  • PCIEXillybus

This is the set I got from the new package and from my source builds from github. The list differs from the published documentation – which I found unsettling. That is when I decided to fall back to the PPAs which listed a totally different set of connections/drivers for the same Mini.

It is not clear, to me at least, how the mini documentation differs from LimeSDR USB. Is there a good source of pure LimeSDR Mini documentation or something that describes the differences? Should I ignore the SDR USB docs altogether? How can I best sort out what is what? It seems like my ARM builds were functional at the lower layers and perhaps only osmo-trx was giving me grief.

gqrx seems happy now and this at least establishes a baseline for me to have comfort moving forward.

If anyone is interested a simple script to {in|un}stall the stack from packages you can find it here:

https://pastebin.com/jDT582WS
if you use the -c switch, it will conveniently uninstall the stack first. I suppose upgrade would probably do the trick but the reptile part of my brain finds this more deterministic.

thanks,
j.


#6

I think FT601 is the FTDI chip used in LimeSDR Mini and FX3 is the Cypress chip used in LimeSDR.


#7

That’s right and PCIEXillybus is the one use with the LimeSDR-PCIe board.


#8

Jason, thanks for the install script!


#9

have you successful use limesdr mini on ubuntu ?i have just success one time ,and now it cannot work.
when i run osmo-trx by shell [ osmo-trx-lms -C cellular-network-configs/osmocom/osmo-trx-limesdr-mini.cfg
], its seams run successful .but when i run openbts, the shell echo flowing:

1535791677.882601 139937790596928:
Starting the system…
ALERT 3217:3217 2018-09-01T16:48:03.1 TRXManager.cpp:402:tune: RXTUNE(53) failed with status -1
EMERG 3217:3229 2018-09-01T16:48:07.8 TRXManager.cpp:107:clockHandler: TRX clock interface timed out, assuming TRX is dead.


#11

How I ran osmo-GSM on kali on my laptop with usb 2.0:
1 - https://www.trustedsec.com/2018/10/a-buyers-guide-to-beginning-sdr/?utm_campaign=Blog%20Posts&utm_content=78790549&utm_medium=social&utm_source=twitter
2 - https://osmocom.org/projects/osmotrx/wiki/LimeSDR_Build_From_Source
3 - Don’t use Virtual Machine
Works very well
P.S. i use LimeSDR mini


#12

New LimeSdr mini with HW 1.2 and last limesuite 19.01 not work with osmocomtrx…Any suggest ?
Tried with all Ubuntu version in different pc. Problems with TX calibrate.
I tried the firmware 1.28 and 1.29 …Nothing.