The Myriad RF and DEO – Nano development project kit installation procedure

It looks like COM3 is not associated with the interface board. I did not find out how to verify that COM3 exists in the Device Manager but I used a Terminal Software which indicated that COM3 exists even if unplug the interface board.
Still, in the Communication Settings in ctr6002dr2 software this is the only possible selection.
How can I enable the Cypess comport interface?



That’s weird!! Check this datasheet below. I found this from interface board schematics:



When you plug the interface board, do you see any change in Device Manager? Usually you should see something under PORTs.

Your question really surprised me, no ports in the Device Manager?
Well, you are correct, no ports!
So, I googled: no ports in device manager and everyone are pointing to device and printers. And there it is, the “ZydrunasLM2v” device is under “Unspecified” section. I have no options to “map” it to a com port or anything.
I’m starting to think that going with the Cypress option was not a very good choice for the interface board. At least to for Windows 7 64 bit.
Unfortunately I ran out of XP machines after my last attempts messed up the driver installation in all of them. I’m trying to workout a solution for the XP machines but would very much like to know if there is a solution for my Windows 7.

A short update,
I finally managed to get my XP computer to install the correct driver. The driver installed with the Cypress software does not support the correct PID. The “corrected” driver is in the latest software distribution v1r0.01.
After installing the diver the XP machine actually acts exactly like the Windows 7. When plugging in the interface board a new active USB device is added under USB controllers. There is no new Port under Ports. My XP machine has two serial ports, COM1 (a physical RS232 port … its a very old computer) and COM3 (the modem comport).
Should there be something else?
When running the ctr6002dr2 it acts the same. Register test is stuck. No activity on the SPI bus. Cannot even toggle the hardware reset pin using the Global Reset switch in the “TopLevel” tab.

I woke up this morning and decided that maybe going with the 1v08 firmware was not such a good idea.
I programmed the interface board firmware version to 1v06 (named firmware_v1r06.iic) and the provided gateware, “demo_txcw.sof”, to the DE0 nano board.
As written in the development manual I removed the SPI resistors listed in table 5, page 22. I did notice that there is a mistake there regarding the resistor on the RESET pin.
I removed resistor R56 and not R58 prevent contention between the FPGA and the on board I2C to SPI chip.
And behold, everything is working perfectly. The software lunches immediately and all register tests pass!
I do not think that the issues with firmware 1v08 are related to the comport in the PC.

Hi Moti,

That’s is good news!! and a bit of headache for me, why is not working as it should be?! I’ll double check on files (firmware and gateware).

Thank You

Hi Andrew,

I apologize for the headache :slight_smile:
Continuing my installation I found that the *.inf file in the cybus_driver directory for Windows 7 x64 does not include the association for PID DE02 which is required for firmware_v1r06. I had to add it manually. Then, the driver installation works. My first test was made with my old XP laptop.
BTW, I would be happy to help test any updates you have regarding firmware_1v08.

I also noticed that the gateware provided with the latest software does not include the receive path capturing buffer which is probably required for the FFT viewer. I will try to add that myself and will be happy to submit the version if it may help others.

Thanks for the support,

Thank you Andrew,
so after having replaced the I^2C Bridge the board worked at a normal state again. Unfortunately the option to control the SPI via USB Microcontroller does not work at all at my board (With DE0-Nano Board being unplugged and using firmware_1v08.hex). After I started the software the microcontroller sends continuously clock and data to the I^2 Bridge but this bus does not forward any data or something. The measurement equipment displays no changing in signal levels.

Now I removed the Resistors and control the SPI via FPGA. All register tests are fine now.


@Molito @Robert,

I have double checked the files on GIT repository for DE0-Nano board ( link ), and I could not find any mistakes. So it should work as intended.

Did you downloaded files from same repository? It has been updated recently.


Hi Andrew,
I downloaded the latest files from the link in the website software tab. I can try downloading the latest version and check it after the weekend (can’t solder the resistor back).
If the version in the software tab is not valid I suggest removing it and pointing directly to the repository.
BTW, I also found that the software did not write the FPGA registers correctly. The problem I found is in the write command protocol in file “dlgSerPort.cpp”. For all “CMD_CFG_I2C_WR” commands, Buf[3] was set to the length and Buf[2] was not initialized. I changed:
Buf[3] = 1; // write command length
Buf[2] = 1; // write command length
Buf[3] = 0;
Now FPGA writes work OK. Hardware reset is working.
I will check if the latest version in the repository has this fix.

OK, that make sense then. The version you are using is very old and it not suppose to be on the website. Use files shared in GIThub only. That should sort out the issue with software you are having.

I’ll take care of the old files on the web.


I just compared the latest software (ctr6002dr2) version and it’s identical to the 1v01 snapshot from the software tab. So, this software will not solve the FPGA write issues I reported above. I did not test the 1v08 firmware yet but will report later.
Regarding the FFT viewer, is there a possibility to publish the source code?


I’ve put FFTviewer source code in dropbox, link below:

Hi Andrew,

I tested the new FFTviewer software with firmware 1v08 and it looks great.
Still need to understand better how does the software works but all register tests are passing and both transmitter and receiver are working in the software. I did notice that not all the features in the software “transmitter” tab are implemented but I guess it is not a formal release yet.



You can access complete transceiver control from Tools menu. Try it on!


Hi Olee_side,

I confuse that this flow is SPI via USB controller or SPI via FPGA??



I try to use the Myriad RF, the DE0-Nano board with digital interface board V1.0.
I have lot of problems and i think my problems come to software, firmware or the gateware.
My OS is Windows 7 64bits.
If you managed to use the platform as described in "Myriad -RF development kit_1.0r6 " document I am interested by a tutorial and a compressed file with all that is required.

Thank you in advance for your assistance with this.

Hi ritchy,

I also try to use the MYriad RF, DE0-Nano… and i have also the same problems

did you find a solution ?

hi Andrew,
do you have the firmware_1v06,if you do,could you please give me it ?thanks!