The Myriad RF and DEO – Nano development project kit installation procedure

After the following installation procedure, you will be able to control Myriad RF board via mini USB connector on the interface board, using the supplied GUI. Also the interface between FPGA and LMS6002DFN is configured as part of the installation process.
Follow the steps below:

  1. Download the software package.
    Download the software package from this: “”

  2. CyUSB installation
    To be able to download firmware to USB microcontroller, download and install “CySuiteUSB_3_4_7_B204.exe” file from: “”, or from “cyapi” folder.

  3. Driver installation
    Connect Digital Interface board to the USB port on the machine running MS Windows operating system. Driver installation window will then pop-up. Select the driver from “cyusb_driver” folder provided.

  4. Firmware download to USB microcontroller
    After driver installation is done and CySuiteUSB software is installed, run the “USB Control Center” application. On the left side pane of the program there is USB controller. Select this controller and choose menu item “Program FX2 -> RAM”. Select HEX file “firmware_v1r06.hex” provided in the “firmware” folder.

  5. Gateware download to the FPGA
    Download FPGA bitstream file “demo_txcw.sof” provided in the “gateware” folder as described in “DE0_Nano_User_Manual_v1.5.pdf” file in “de0-nano” folder, chapter “6.9 Program the FPGA Device”, as given on page 77.

6.Running the software
After USB driver is installed, firmware and gateware are downloaded, start the GUI software “ctr_6002dr2.exe” from the “software” folder. This enables you to control the LMS6002D chip on MyriadRF board. Before doing so, it is necessary to upload configuration to the Si5356A to provide clocks to the LMS6002D PLL, ADC/DAC’s and FPGA. To do this go to the “Board” tab in the GUI and click on the button “Upload register map to Si5356A”. This will upload register settings to the Si5356A and all the necessary clocks will be generated.

  1. Result
    The function of the FPGA is to generate and send CW of frequency 3.84MHz to the LMS6002D’s DAC. FPGA starts to transmit CW as fast as bitstream is downloaded.


I am interested in RF communications recently, new on it. Last week i purchased two development kit (Myriad rf board, interface board and de0 nano board) to communicate each other, now waiting for the delivery.

When kits are delivered, how can i run the kits quickly , Are there other some example codes, tutorials, projects.


Hello Mustafay87,
Here it is complete manual description on how to set up the whole development kit.
One of the latest software projects you can find on this website is the “FFTviewer v1” designed to run on interface board connected to the DE0 Nano bord and Myriad RF board. All information about it you will find on this link:
To be able to run FFT Viewer, you will need to install FPGA. How to do that you will find in Manual section “4.3.1. FPGA software Installation procedure”. For “FFT Viewer” instead ”demo_txcw.sof “ described in manual, please use file “bin_nco_to_USB_packet.jic“. You can download it from here:

Hi @all,

I´m trying to getting started with this MyRiad RF Set which consists of The DE0-Nano Interface Board, the DE0-Nano Cyclone 4 FPGA Board and of course the MyRiad RF Board. And there is still no problem occuring till step 6 as olee_side described. There are different problems occuring apperantly randomly.

Either when trying to start the ctr_6002dr2.exe an error message appears with “Access Violation at address 004ADCBB” in module ‘ctr_6002dr2.exe’. Read of address 000 000 00,
The Software doesn´t start at all when connected to the mini USB COnnector
The Software appears but hangs up if I click the “Upload register map to Si5356A” respektively when I want to proceed a Register Test

The Board is run by a 5V DC via the J9 Power Supply

For your answer I thank you very much in advance

Hi, try to see this video. It shows how to upload clock synthesizer. This particular moment in around 1:41 minute.

If it doesn’t help. Let me know. Good luck.

Thank you Solutions_OK,
unfortuantely the video does not concern my problem accurately.
As I said I can program the FPGA with the “demo_tscw.sof” data, or rather said the Quartus 2 Programmer gives me the response that the FPGA could be programmed to 100% success. Then the USB SUite Control Center gives me the message that the RAM could be programmed with the firmware “firmware_1v08.hex” respectively “firmware_1v06.hex”. But then if I want to start the ‘ctr_6002dr2.exe’ I can´t do anything. As I said I get different problems as I described in my last post. And I don´t believe that I need the 30,72 MHz PLL beeing connected when I just want to perform a Register Test.

One more Question in the video he used the option ‘Load register map from file’. Is there a Initialization data I can use to test if it works properly or do i have to program one of my own? BTW. All of these Applications are run as administrator!

Thank you very much in advance


You have have to use firmware “firmware_1v08.hex” only. As well check if on your board you have fitted R51, R46, R52, R48 and R56. If remove them. These resistor are interface board top layer between pinheader for DE0-Nano board.


Thank you Andrew,
I like to ask you one more question before I will remove these resistors.
According to the developement kit manual these resistors (with 0 \ohm) shall be fitted if I want to control the LMS6002 chip. In this setting the firmware_v1r08.hex is needed. And I would like to use this setting (control myriad board via USB Microcontroller). Additionally you have to set the FPGA lines SPI_NCSO, SPI_MISO, SPI_MOSI and SPI_CLK to ‘tri-state’. Can you please explain why this is needed when Iḿ not even have plugged in the DE0 Nano Board or dont want to control the Kit with it? And how can I set these Pins to ‘tri-state’?

But if I follow your advice and remove these resistors (that is the case if you want to control the LMS6002 chip, or in common the MyRiad Board, via the FPGA) then I would have to use firmware_v1r06.hex and not the other one what you told me. SO I am a little bit confused now. Could you please explain that matter once again? =)

Thank you in advance

Hi Andrew,

I received my development kit a few days ago and tried to install it. After numerous failures, which I will not go through here, I programmed “firmware_1v08.iic” to the interface board. Now the board is not recognized by the driver at all. It just appears as “USB device” in the device manager. The state of J5 does not affect this!
I found this topic and noticed that you wrote that only “firmware_1v08.hex” should be used.
How can I revert this back?


Hi Motilito,

it doesnt matter wheather you use firmware_1v08.ICC or firmware_1v08.hey. You only have to mind that the hexadecimal stream is used for the Random Access memory whereas the iic-file is for the EEPROM 64kb memory only. So according to the developement kit manual exactly your problem can occur and the solution is to install the USB Generic driver once again after having programmed the USB microcontroller. So you dont have to revert this back.


Thanks Robert,

That was a very fast replay. You are right, it seems like a driver problem. I’m changing the computers all the time but this is probably a problem with the Cypress driver.
I programmed firmware 1v08 to the EEPROM and the interface board now boots OK. I can see that the clock synthesizer is initialized after I execute the “ctr_6002dr2.exe” control GUI.
The problem is that register test fails all tests. This happens with or without the FPGA board installed on the interface board. All register tests return value 00. According to the manual this implies that the problem is a communication problem. This does not make sense however since the clock synthesizer is initialized correctly (I measured the clock frequency using a scope).
I programmed the DE0 FPGA board with the given firmware version. After programming the the default LED pattern stopped.
I looked at the SPI_CLK and it does not change its state during the register test.
Any ideas?



Yes, you are right. There are two ways of controlling LMS6002D chip on DE0-Nano interface board: establishing SPI via FPGA (then you have to use firmware_v1r06.hex file) or via USB micro-controller (…to use firmware_v1r08.hex file). In the last one, you don’t need to do any modification to the board and SPI should work without DE0-Nano board. Sorry for making confusion.

When you connect the DE0-Nano board to the interface board, you have to program FPGA with provided *.sof file. This will set some FPGA pins, which are by hardware connected the SPI interface, to tri-state mode to prevent interference.

One possible issue might be that you are not selecting correct COM port in a GUI. Can you double check that?

Sorry for making confusion.

@ Motilito

Check if you are setting the correct COM port in your GUI.To do that:

  1. Check COM port number for interface board in Device manager.
  2. Go to go, select’Options’>>"Communication Settings’
  3. In the pop-up box tick “COM” and below select the correct COM port for the interface board.


Hi Andrew,

Thanks for information regarding the two firmware versions. It did not appear in the development kit manual.
Regarding the COM port setting, I’m afraid your description does not match what I see in the GUI. When I open the “Communication Settings” dialog the “USB” radio button is selected. When I click the left pull down menu, under the “COM” radio button, an empty list pops out. In the right pull down menu, under the “USB” radio button, a single option is displayed: “ZydrunasLM2v”. The default USB end points are selected: “cmbInEndPt”, “cmbOutEndPt”. I did not change the SPI clock frequency settings from 4MHz.
Are these settings correct?


BTW, I removed the FPGA board just to make sure that it does not contend over the SPI bus.
For now I’m just trying to configure the LMS6002 through the GUI.

Hi again,
I’m sorry for filling up the forum but I thought I should make two additional observations:

  1. When programming the 1v06 firmware version, the device manager refreshes and the USB device that was identified as “Cypress Generic …” is now tagged “USB Device”. Any attempt to install the driver fails. It looks like this is the point that messes up the driver installation. Note that I removed the FPGA board from the interface board. I do not know if this causes the CPU to get stuck so USB initialization fails.
  2. Reprogramming the 1v08 firmware initializes the USB correctly. I monitored the I2C bus using a scope searching for CLK activity. When the board powers on, after connecting to the USB, a short activity is monitored. I also monitored the FPGA_CLK from the synthesizer and it’s not running. After running the ctr6002dr2 software the FPGA_CLK starts running at 30.72MHz, same as the onboard ascillator. The I2C_CLK keeps running FOREVER. It looks like the communication between the PC and the board is working since running the software did start the clock synthesizer and I2C is running. Register test hangs is just stuck, Not Responding is all I get.
    I hope this information helps,


This seems to be correct, because using 1v08 firmware the SPI is established via Cypress microcontroller.

The problem is with GUI it self, if should show available COM ports. Did you run it as administrator? Right click on executable file and select “Run as administrator”. The account control window will pop up, just press “yes”.

Try this and let us know if that helps.


Hi Andrew,

After running the software as administrator the port number popup list is not empty. The only option, “COM3” on my laptop, is selected.
The rest is the same. Register Test is stuck and windows displays “Not Responding”. I tried toggling the Global Reset switch. It takes about 10 to 15 seconds just to change its state. The console in the bottom of the GUI prints reset ACTIVE but the board reset signal is unchanged (logic high, reset inactive).


Does the COM3 stands for interface board? You can check in Device Manager by unplugging and plunging back the interface board to PC.


Hi again,

unfortunately the I^2C has been shortcutted for whatever reason, so I cannot test your instructions :(. Has something happened in the works of somebody else? Is it possible to get the data sheet for this chip?

Thank you in advance