PiHPsdr


#61

Here’s the latest from John Melton (G0ORX) himself as a friend of mine (who’s also doing development on PiHPSDR on an Odroid with the Red Pitaya and works directly with John on issues and resolution of the app (see pic):

So what it means is…until that debugging is done LimeSDR is not going to be discoverable.

…And thus, we wait…

73 de Marty, KN0CK


#62

That may be true using PPA, but i can AND do discover LimeSDR with pihpsdr on an Odreoid-C2 running Ubuntu 16.04 Mate …

perhaps its just a Rasperian issue … iv seen others not get SoapySDR/gqrx not working too with RaspBerian …


#63

Mike,

I did mine as a complete set of installations from source and compiled everything. There’s a small trick to making Soapy and LimeSuite operate on the newest version of Raspian, but I have Soapy and Lime resources working on my RPi3. I’m certain you cannot use PPAs for that set of installs…I just cannot detect the LimeSDR on PiHPSDR even though when I do a SoapySDRUtil --find it finds my board just fine…It just cannot discover it during the discovery phase at the beginning…But it can find my Red Pitaya.

I really think this is related to discovery mode working for ethernet and not USB - - the terminal windows never shows a USB discover, but you can clearly see where it’s doing an Ethernet discovery.

73 de Marty, KN0CK


#64

Wonder if its a UDEV issue still or a permissions …
try a sudo pauspender – ./pihpsdr (i probably spelled pauspender wrong again)
EDIT (RasberryPi does not use pulseaudio, pauspender is meaningless)

VIDEO in a bit …

AND a probable GQRX bug at time 6:15 or so …


#65

With pihpsdr I only get RX spectrum, waterfall and audio output with ANT–> RX1:NONE.

I have the ANT connected to the port in line with where MN18 was removed, i.e the second port in from the left viewed with the USB and power input closest to me.

Also can’t change VFO A frequency with mouse.

Just checking to confirm antenna selection is OK.


#66

Mose or other to chane not working 4 me … i edited the ##$%%^^ file to change the center frequency

I cant remember the antenna … but you can change it to which ever #1 antennas … i use wide


#67

Checked the circuit diagram and connection is RX1_L so in pihpsdr selecting RX1:LNAH, LNAL or LNAW should work.
Problem must be in the code.


#68

Ummm … does opengl rendering work?
What devic e do you have the LimeSDR-USB connected to?


#69

Un mine … u can see a waterfall on all selections … signals when the port with an antenna is selected…

I had to make other code modifications because of USB2 limitations… if i get time this weekend ill email ya what i did Sid …

Maybe you can find the code where the samples per sec are and change it to a lower value …


#70

ODROID-C2’s USB 2.0. No opengl problems.
Samplerate settings in pihpsdr 1M or 2M.
If you have time, would appreciate your changes.


#71

Does TX work in PiHPsdr with the limesdr?


#72

Jaime,

I am told by those working closely with John Melton (G0ORX, the creator of PiHPSDR) that he intends to work on the LimeSDR transmit next since receive is already working. His major work to make the TinkerBoard work and have PureSignal working is done, so I was told that his next endeavor would be to make the LimeSDR operate with transmit and receive on the PiHPSDR. I have his most recent build of PiHPSDR with even digital voice working great on the Red Pitaya SDR, and PureSignal is plumbed-in, too. So there’s no reason now that he can’t start work on the Lime. No ETA yet on when that will be done - I will keep the pressure on this, too.

Also, there is movement from another company based in Russia that is planning to develop a WONDERFUL Windows platform app for the LimeSDR - I’m also applying pressure to make that a reality, too - that software app will be INCREDIBLE when it’s done. I am told that this company will be starting that effort soon (August) and plans to have it in beta form in 90 days - TRANSMIT AND RECEIVE.

Stay tuned…

73 de Marty, KN0CK


#73

I would caution against pressuring John.
I received an email reply from him yesterday saying that he hopes to start on this works soon but he is absolutely snowed under with lots of other vital pursuits that are of an urgent nature.

With pihpsdr v1.1.3-beta I get no signals from LimeSDR.

CubicSDR on an ODROID-C2 is not smooth.
pihpsdr doesn’t build on x86_64 Ubuntu 17.04 or openSUSE tumbleweed.


#74

Should on x86_64 16.03 ubuntu …


#75

May be a problem in Makefile? Only changes made.

uncomment the line below to include GPIO

####GPIO_INCLUDE=GPIO
UNAME_N=up

uncomment the line below for LimeSDR (uncomment line below)

LIMESDR_INCLUDE=LIMESDR

root@sdrbox:/usr/src/pihpsdr# make
rm -f version.o
gcc -g -Wno-deprecated-declarations -D up -D LIMESDR -D GIT_DATE=’“2017-06-10”’ -D GIT_VERSION=’“v1.1.3-beta”’ -O3 pkg-config --cflags gtk+-3.0 -c -o version.o version.c
gcc -g -Wno-deprecated-declarations -D up -D LIMESDR -D GIT_DATE=’“2017-06-10”’ -D GIT_VERSION=’“v1.1.3-beta”’ -O3 pkg-config --cflags gtk+-3.0 -c -o meter_menu.o meter_menu.c
meter_menu.c: In function ‘smeter_select_cb’:
meter_menu.c:45:10: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
smeter=(int)data;
^
meter_menu.c: In function ‘alc_meter_select_cb’:
meter_menu.c:49:7: warning: cast from pointer to integer of different size [-Wpointer-to-int-cast]
alc=(int)data;
^
meter_menu.c: In function ‘meter_menu’:
meter_menu.c:77:74: error: ‘RXA_S_PK’ undeclared (first use in this function)
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (smeter_peak), smeter==RXA_S_PK);
^~~~~~~~
meter_menu.c:77:74: note: each undeclared identifier is reported only once for each function it appears in
meter_menu.c:83:77: error: ‘RXA_S_AV’ undeclared (first use in this function)
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (smeter_average), smeter==RXA_S_AV);
^~~~~~~~
meter_menu.c:89:68: error: ‘TXA_ALC_PK’ undeclared (first use in this function)
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (alc_peak), alc==TXA_ALC_PK);
^~~~~~~~~~
meter_menu.c:95:71: error: ‘TXA_ALC_AV’ undeclared (first use in this function)
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (alc_average), alc==TXA_ALC_AV);
^~~~~~~~~~
meter_menu.c:101:68: error: ‘TXA_ALC_GAIN’ undeclared (first use in this function)
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (alc_gain), alc==TXA_ALC_GAIN);
^~~~~~~~~~~~
Makefile:366: recipe for target ‘meter_menu.o’ failed
make: *** [meter_menu.o] Error 1
root@sdrbox:/usr/src/pihpsdr#


#76

I think something else is not built that this is dependent on …

Look in the RasberryPi build document … or the install script for the Pi …


#77

Thanks Mike, it’s in wdsp.h.
wdsp.h is in /usr/local/include but it looks like it wasn’t finding it.
Updated and reinstalled wdsp and pihpsdr now builds

Still looking as SoapySDRUtil and pihpsdr can’t find it but LimeUtil and LimeSuiteGUI both can.
slipstream:/usr/src/XXX/pihpsdr # ldd /usr/local/bin/SoapySDRUtil
linux-vdso.so.1 (0x00007ffc033b3000)
libSoapySDR.so.0.6 => /usr/local/lib64/libSoapySDR.so.0.6 (0x00007f97ec790000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f97ec588000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f97ec200000)
libm.so.6 => /lib64/libm.so.6 (0x00007f97ebee8000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f97ebcd0000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f97ebab0000)
libc.so.6 => /lib64/libc.so.6 (0x00007f97eb708000)
/lib64/ld-linux-x86-64.so.2 (0x00007f97ec9d0000


#78

Sent you my build … dont have time right now to look to see what i did …

Though the .pros file contains the band center frequency … i changed band 4 to 10mhz, prolly better to be 10.01mhz … but it gives you an idea of how to move the band center display to what you want


#79

I had probems with soap/lime/gqrx …

If it was looking in the right place and still not finding i would manually delete the .so* and simply issue again from build folder sudo make install …

I still get odd-ish-long system pauses on my C2 …
Kind like what the X2 would do for the first 3 years …


#80

I saw the same pauses running CubicSDR on the -C2, that’s why I thought I would try some other apps.