LimeSDR USB with Raspberry Pi 4

Hi guys,

I’ve been trying for weeks now to get my LimeSDR USB working with my Raspberry Pi 4. I’ve tried various OS (Raspbian, Ubuntu 18.04) to get the LimeSuite and GNU Radio, but the Pi always seems to crash when installing the gr-limesdr plug in.

Are there any suggestions to getting this working? I really would like to get this working.



If all you want to do is to use the LimeSDR as a SDR, on the Raspberry Pi 4 -

sudo apt-get install cubicsdr

should install CubicSDR and the required libraries - so you can listen

I want to be able to drive a low powered PA with the LimeSDR. Also to use GNU Radio to do a transmit and receive, with some DSP blocks.

I’ve gotten LimeSuiteGUI and GNU Radio installed on the Raspberry Pi running Ubuntu 18.04, but I can not get the gr-limesdr plug installed.

When installing gr-limesdr from PPA, I run:

sudo add-apt-repository -y ppa:myriadrf/drivers
sudo add-apt-repository -y ppa:myriadrf/gnuradio
sudo apt update
sudo apt install gr-limesdr

But get the error:

E: Unable to locate package gr-limesdr

I’ve tried installing it from source, but it freezes then eventually is unable to install

The SDRPlay version of the raspberry pi system -

has a working version of gnuradio. I ran a fm receiver with the Lime Mini using gnuradio-companion on my Raspberry PI 4.

armhf build had been disabled in the PPA, since Launchpad uses Qemu for this and it had limited resources, so building GNU Radio would fail and generate errors. Canonical may have since increased available resources and so I’ve just re-enabled armhf and also enabled arm64.

@Garmus could you push an updated gr-limesdr (just new minor/patch version if no update code available) to trigger a new build.

1 Like

Hey, I pushed the newest gr-limesdr to repositories. It seems that arm64 and armhf were build successfully.


Many thanks, appreciated!