LimeSDR-USB GW 0 Ver 0

#1

Hi limesdr enthusiast,
I finally got some time to play with the LimeSDR-USB I bought, and after succesfully installing the driver and the photos sw I faced the GW 0 Ver 0 issue.
I went through all the posts that talk about this issue and did many testing:
=> tested in two different laptops in USB 3.0 and USB 2.0 port.
=> Tested with a 12V 1A power supply.
=> Tested with an industial hub that can source 4.5A per USB 2.0 port.
=> Tested with the quasi all the Limesuit from 2018 up to 2019.
I got the same behavior:
When the board is powered, only the led 8 is green. All the others are tuned off.
If I exercise a small pressure on the FPGA, I got the LED 8 green, the LED 2 green and the LED 1 blinking red and green. If I reset the FX3, I go to the LED 8 green state again.
Sometimes after the small pressure, I got the LED 8 Green, LED 2 red and LED 1 blinking red and green.
All this suggest that there is a HW failure. I was planning to JTAG the FPGA but the pod I have is not compatible with the small connector on the card.
Can someone help with this issue?
Thanks.
PS: Copy of the log:
/*************************************/
C:\Program Files\PothosSDR\bin>LimeUtil.exe --make
Make device
Undefined/Failure
Gateware version mismatch!
Expected gateware version 2, revision 21
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update
Undefined/Failure
Device name: LimeSDR-USB
Expansion name: UNSUPPORTED
Firmware version: 4
Hardware version: 4
Protocol version: 1
Gateware version: 0
Gateware revision: 0
Gateware target: UNKNOWN
Serial number: 0x9070602460925
Free connection… OK

C:\Program Files\PothosSDR\bin>LimeUtil.exe --update
Connected to [LimeSDR-USB [USB 2.0] 9070602460925]
Undefined/Failure
Gateware version mismatch!
Expected gateware version 2, revision 21
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update
Undefined/Failure
Existing firmware is same as update (4)
[100%] 580050/580050 Bytes programming: completed (C:\Users\abou\AppData\Roaming/LimeSuite/images/19.04/LimeSDR-USB_HW_1.4_r2.21.rbf)
Programming update complete!
C:\Program Files\PothosSDR\bin>LimeUtil.exe --make
Make device
Read(64 bytes) failed
Gateware version mismatch!
Expected gateware version 2, revision 21
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update
Read(64 bytes) failed
Device name: LimeSDR-USB
Expansion name: UNSUPPORTED
Firmware version: 4
Hardware version: 4
Protocol version: 1
Gateware version: 0
Gateware revision: 0
Gateware target: UNKNOWN
Serial number: 0x9070602460925
Free connection… OK

#2

This really suggests soldering issue. Check with Crowd Supply if it possible to replace your board.

#3

Thanks for the feedback Zack.
While I understand the issue, I really don’t get it how this can pass the QC. I already faced problems with FPGA soldering issues, but usually it was with high IO parts (more than 900 BGA balls) and large PCBs that tend to bend.
Any way, I’ll contact Crowd Supply and hope to be back with more interesting questions to this forum.

#4

I’m trying to get in touch with the support guys at Crowd Supply to figure out how I can resolve this issue.
I asked for an RMA and tried to reach Crowd Supply personnel directly without any result up to now.
Is there some folks that can help with this in the forum?
It’s starting to be really annoying…