LimeSDR-USB fails during Quick Test

#1

I’ve just pulled my LimeSDR-USB off the shelf (where it’s been sitting since the original crowdfunding run). I’m using macOS 10.13, and installed LimeSuite 18.04.1 with homebrew.

LimeUtil --update successfully flashed LimeSDR-USB_HW_1.4_r2.16.rbf and LimeSDR-USB_HW_1.4_r4.0.img

When I run through https://wiki.myriadrf.org/LimeSDR-USB_Quick_Test I connect to the board, open “self_test.ini”, click “GUI–>Chip”, but when I press “Calculate” in the SXT tab, I get a popup saying “Set SX frequency failed” and a red message in the log section of the window “[11:31:03] ERROR: SetFrequencySXT(2140 MHz) - cannot deliver frequency”

If I continue on, everything throws more errors (SXT > Tune, “SX VCO Tune Failed”, CLKGEN > Calculate, “CLKGEN: failed to set interface frequency”).

Is this expected? User error? Hardware fault?

#2

Hi @russm,

What USB port (USB2 or USB3)? I would suggest to use Linux or Win machine for this test.

#3

I’m using a 2017 MBP, USB-C (USB 3.1). Are you saying macOS is unsupported?

#4

same result using Linux (Debian buster, LimeSuite 18.04.1) on 2 different hosts, both USB3 - 2017 MacBook Pro (USB-C), and 2012 MacBook Air (USB-A).

#5

How did it go? So it doesn’t support MacOS?