LIMESDR on SRSLTE : unable to find network on LTE device

hi guys,

I was following a post (https://cyberloginit.com/2018/05/03/build-a-lte-network-with-srslte-and-program-your-own-usim-card.html) on setting up an LTE network with the lime sdr over srsLTE interface.

Strangely, when i run my epc and enb, its all good, even a spectrum analyser can pick up the signal of the base station. But when i try to search for the LTE network on my phone, i get nothing. the network doesnt show up. I’ve tried changing the earfcn frequency to other values but nothing still.

i even tried putting the programmed sim card in the phone and searching, still nothing.

what am i missing?? if you have an idea, please help out.

There was a good talk about a month ago at the 2019 CCCamp on the limitations of general purpose SDR. And it focused on “Why an SDR board like a USRP or LimeSDR is not a cellular base station” https://media.ccc.de/v/Camp2019-10248-the_limits_of_general_purpose_sdr_devices (and the exact same same video is also at https://www.youtube.com/watch?v=JgRCvzTuGkE ). Which may contain the answer to your question.

The on-board clock for both the limeSDR-USB and LimeSDR-Mini are given as +/- 1 ppm initial, +/- 4 ppm stable. So my guess with almost zero knowledge about LTE would be that you probably need a more accurate external reference clock, something along the lines of : http://www.leobodnar.com/shop/index.php?main_page=index&cPath=107

And if you configure your external reference clock to be 30.72 MHz for the LimeSDR-USB, that would probably require the least effort.
ref: https://wiki.myriadrf.org/LimeSDR-USB_hardware_description#Clock_distribution

Or configure your external reference clock to be 40MHz for the LimeSDR-Mini (but you also need to make a hardware change to a mini to enable the external reference clock and (permanently) disable the on-board VCTCXO).
ref: https://wiki.myriadrf.org/LimeSDR-Mini_v1.2_hardware_description#Clock_Distribution the actual position of the resistor to move is detailed a bit clearer here Enabling External Clock on LimeSDR mini 1.2?

3 Likes

hello twabi
did u manage to solve this issue as iam facing the same problem
tried every thing although the srsepc and srsenb r behaving probably.

Its not the clock stability in general, but the (lack of) initial calibration is the main issue.

Sure thing: the 1-2ppm stability of these SDRs does not meet the strict telco BTS requirements (which is 0.5ppm or better), but most of the phones do tolerate more freq errors than that. On the other hand, my LimeSDR mini was producing a 12kHz freq error on 2GHz, which is very far from the 1-2ppm advertised.

So what needs to be done is do a freq calibration, or use a lower band. For example going to 800MHz from 1800MHz will cut the freq error to half.

I am still in a bind. still gotten nowhere. My limesdr has even been configured with the 30.72MHz clock reference but still nothing. But i agree with the fact that SDR in general has stability issues with regards to using them for cellular networks.

Have u tried to use external clock