LimeSDR-mini on VirtualBOX

Any one have tried out to use LimeSDR-mini on VirtualBOX environment ? I have difficulty to use LimeSDR-mini in VirtualBOX environment. While LimeSDR is OK, but LimeSDR-mini fails to connect in VM.

Interestingly, when connected to physical USB2.0 port, it works OK, but not USB3.0.

My setup is as follows:
Host PC: Windows10 X64; have USB2.0 and USB3.0 ports.
VirtualBOX: v5.2.8
Ubuntu16.04 (in VittualBOX)

Message from dmsg command when failed to connect:
[32576.216792] usb 1-2: new high-speed USB device number 6 using xhci_hcd
[32576.433625] usb 1-2: device descriptor read/64, error 18
[32576.769165] usb 1-2: device descriptor read/64, error 18

Any comment is appreciated. Thank you.

@mars999 - Keiichi,

The only thing I’d recommend is looking at the USB specs in Virtualbox - they are settable to USB 2.0 or USB 3.0 in the settings window and will work with the appropriate ports on your PC. Please review the settings and see if it’s not set to USB 3.0 - that will often resolve the issue.

73 de Marty, KN0CK

Thank you for your advice.

USB setting in VirtualBOX is USB3.0.
On same environment, LimeSDR works without any problem.

When booted up native Ubuntu 16.04 from external storage device, it worked.
My guess is compatibility problem between USB chip FTDI FT601 in LimeSDR-mini and VirtualBOX ??

1 Like

@mars999 - Keiichi,

As long as the FTDI driver is loaded in the virtual environment you should be good to go - it would also help if the FTDI driver was loaded on the PC, too, to prevent an issue between the virtual environment and the host. Hope this helps - keep us all advised on your progress.

73 de Marty, KN0CK

I have installed FTDI driver in my PC too,and host OS can find LimeSDR-mini.
Any way, I will try to find way around the problem if possible.