How to fix the error: Tx Calibration: MCU error 4 (SXT tune failed)

I run the srsLTE srsUE with Lime-Mini in Ubuntu, and always show the MCU error 4.

Some of the logs here:

[INFO] TX LPF configured
Set Tx bandwidth to 5.00 MHz
Setting up RX stream
Setting up TX stream
Available device sensors:

  • clock_locked
  • lms7_temp
    Available sensors for RX channel 0:
  • lo_locked
    Tx calibration using MCU INTERNAL loopback
    Tx ch.A @ 1240.01 MHz, BW: 5 MHz, RF output: BAND1, Gain: 2
    Current MCU firmware: 5, DC/IQ calibration full
    MCU Ref. clock: 40 MHz
    [ERROR] Tx Calibration: MCU error 4 (SXT tune failed)
    Rx calibration using INTERNAL loopback
    Rx ch.A @ 1200 MHz, BW: 2.5 MHz, RF input: LNAH, PGA: 8, LNA: 15, TIA: 2
    Current MCU firmware: 5, DC/IQ calibration full
    MCU Ref. clock: 40 MHz
    [INFO] Rx calibration finished
    RX | DC | GAIN | PHASE
    —±----±-----±-----
    I: | -2 | 2047 | -7
    Q: | 7 | 2013 |
    Duration: 143 ms
    State of gain elements for Rx channel 0 (AGC not supported):
  • TIA: 9.00 dB
  • LNA: 30.00 dB
  • PGA: -4.00 dB
    State of gain elements for Tx channel 0 (AGC not supported):
  • PAD: 45.00 dB
  • IAMP: 0.00 dB
    Rx antenna set to LNAH
    Tx antenna set to BAND1

I check the code, the error is from LMS7002M::CalibrateTx(), after “status = mcuControl->WaitForMCU(1000);”

And I go into the WaitForMCU(), find the error is from MCU_BD:: mSPI_read(), after “m_serPort->ReadLMS7002MSPI(&wrdata, &rddata, 1, mChipID)”

Hi @allanjin I have the same problem, how did you solve this issue ??

Not yet, I guess it is caused by some hardware performance limits.

Hi @ricardas Have you any comments for this error? thanks a lot!

Doesn’t look like calibration issue, SXT tune is pretty simple. Tx ch.A @ 1240.01 MHz tuning works without problems.

Could it be that your PC USB port does not supply enough power to the device, similar as in this case: https://discourse.myriadrf.org/t/super-frustrated/4425/8

i am also getting this error “MCU error 4”
i have been using my limesdr-mini for over a year with no problems with this laptop and its beefy powersupply.
i only just now started to get that error after i recently upgraded limesuite to 19.01 as per the readme and also installed pothos core per readme.
i then updated my lime-mini with ‘LimeSuite --update’ and it updated the firmware successfully.
i now am getting this mcu error 4.
grrrr

Thanks for your response. I’ll try to test with external power supply.

Could you pls tell me the version NO.? Maybe I can try the older version.

version of what?

Just throwing it out there, I’m running into this problem too with osmo-trx-lms and srsenb and even the associated example tools. Running LS 19.01 and Gateway Firmware 1.29 on a LimeSDR Mini.

again! another one.
i reported this same problem too.

1 Like

To determine if you board is OK, check if you can tune the same frequency using LimeSuiteGUI:

  1. Connect to your board
  2. Press “Default” button
  3. In SXT tab set frequency and press “Calculate” (there should be no error messages).
  4. (optionally) check if Tx calibration works at that frequency by using “Calibrate TX” button in ‘Calibrations’ tab

The error in the first post may appear because Tx calibration is run before setting Tx frequency.

Hey all,

I am having this exact same issue. I got srsENB to work once yesterday and then never again. I don’t specifically recall this error when it was working, but I have it now. It’s very frustrating. Any update on this since the end of April?

To determine if you board is OK, check if you can tune the same frequency using LimeSuiteGUI:

Connect to your board
Press “Default” button
In SXT tab set frequency and press “Calculate” (there should be no error messages).
(optionally) check if Tx calibration works at that frequency by using “Calibrate TX” button in ‘Calibrations’ tab

The error in the first post may appear because Tx calibration is run before setting Tx frequency.

I’m a bit late to the party here but seeing similar issues. I tried the steps above with my LimeSDR-Mini and get “ERROR: Tx Calibration: MCU error 4 (SXT tune failed)” when I click on “Cailbrate Tx”. Even when running the SimpleSiggen.py script I get the same message on the command line. Is there a way to troubleshoot this? I’m using an external powered USB3 hub so I don’t think low power is the issue here…

Try this first:

  1. Open LimeSuite
  2. Go to Options -> ConnectionSettings -> LimeSDR mini -> Connect
  3. Go to “Calibrations” Tab.
  4. Click “Default”
  5. Click “Calibrate RX”
  6. Go to the SXT tab
  7. Click on “Calculate” in the “Frequency, MHz” section.
  8. Click on “Tune” in the “Frequency, MHz” section.
  9. Click on “Read” in the “VCO Comparators” section.
  10. Go back to "Calibrations’ tab.
  11. Click “Calibrate TX”

This should work first. You have to click the “Tune” button after “Calculate”.

1 Like

wow!
i think this just fixed some big problems i been having with calibrate for a long time!
thanks

i did notice the ubuntu LimeQuickTest is failing

ubuntu@ubuntu:~$ LimeQuickTest
[ TESTING STARTED ]
->Start time: Thu Oct 24 19:01:13 2019

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D3BD0C4F0CDFF
Serial Number: 1D3BD0C4F0CDFF

[ Clock Network Test ]
->REF clock test
Test results: 50472; 63669; 11330 - PASSED
->VCTCXO test
Results : 6710990 (min); 6711155 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 03 10 12 03 10 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-27.6 dBFS, 5.00 MHz) - FAILED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-11.2 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.44 seconds

ubuntu@ubuntu:~$