Limesdr mini tx calibration issue

Dear concern,
I am trying to build srslte network with Limesdr mini board v1.3 . every time while running srsenb am getting the error "Tx calibration : MCU error 4( SXT tune failed) .To address this issue I have tried all the solution "How to fix the error: Tx Calibration: MCU error 4 (SXT tune failed) " given here. But all these didn’t work. your valuable suggestions can help me to proceed.i will highly appreciate your help.
Best regards,
Rozana Alam


Could you please run LimeQuickTest and post the results. Please make sure that nothing is connected to the RF ports when this is run and also that the board is cold.

Thanks for your reply. Following is the output of " `LimeQuickTest" for your reference:
->Start time: Wed Oct 14 10:47:00 2020

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D58975046C58F
Serial Number: 1D58975046C58F

[ Clock Network Test ]
->REF clock test
Test results: 50949; 64146; 11807 - PASSED
->VCTCXO test
Results : 6711003 (min); 6711160 (max) - PASSED
->Clock Network Test PASSED

->Read data: 13 0A 17 13 0A 17 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-13.0 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-13.6 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 2.33 seconds

Hi @Rozana,

Could you use the latest LimeSuiteGUI and update the gateware. Then use the latest LimeQuickTest and post the log file again. Try srsLTE again after update.

Hi Zack, I ran exactly the same test here with the master versions of both srsLTE and LimeSuite

Maybe worth merging the threads.