Cypress Driver

Hi There,

I have downloaded the software package for DEO-Nano project. I have followed the installation instructions in Readme.txt file and I am stuck to install Cypress driver. The installation procedure goes smoothly but in device manager window I see that device is not recognized. Any Idea??


Hi form_567,

What is your OS?

form_567 if you are using Windows 7 64 bit OS, you might need to disable the driver signature enforcement, as the drivers are unsigned. See the link below:

When you flash the USB controller on the Interface board, what should the configuration look like in the USB Control center?

If I flash the RAM, the driver gets disabled and I can’t update it. If I flash the EEPROM, the USB Control Center says it was programmed but it doesn’t seem to update anything. And then the Myriad software GUI hangs on startup.

Windows 7


Do you power cycle USB controller after EEPROM flash?

No, I’ve been trying to open the myriad GUI directly after I flash it. But, if I do unpower it, and then come back to it later, Windows doesn’t recognize the Driver anymore, and I have to remove the EEPROM jumper to get the factory firmware, and then start the process over.

64bit Win7 would not recognize the driver after reboot.

You may try the following command by Administrator privilege -

Bcdedit.exe -set TESTSIGNING ON

After reboot, you will see “Test Mode Windows 7” in the right-bottom of your desktop.

You will not suffer for this pain any more.


That didnt make a difference. I tried another windows 7 box (32) and I could flash the RAM. But when I try the register test on the Myriad GUI, it fails.

Hi Gibson,

Does all register test fail?

Couple hints for solving issue:

Before start working with the board, start hardware first and then run the GUI.
In GUI select the communication port: Go to menu “Options->Communication Settings”. Select USB in port selection.
Make sure that Myriad RF is powered. You can power it via the interface board, J1 jumper have to be fitted or supply +5 V directly to Myriad RF board X2.

I hope that helps.


Yes, it looks like all of the tests are failing, and all are receiving 0A

Hi Gibson,

Could you describe your hardware setup in detail? Could you make some photos of the hardware?

Could you describe in detail EEPROM flashing procedure?

I’m using the Myriad RF connected to the Interface Board (both from Azio). I have a HP power supply connected to the Interface Board, and a USB connection from interface board to Windows 7. I tried on a Win7 64 bit box, but had issues with the drivers being recognized after Interface board flash. I have a win 7 32 bit box also, which will recognize the board after I flash it. I see a green light on the Interface board next the power supply input, a green light next to the USB connection, and green light on the Myriad RF board


Steps when I flash:

Remove the EEPROM jumper

Plug in USB to computer

Turn on Power supply to give 5V to interface board

Put EEPROM jumper back on

Open Control Center

Select Flash EEPROM 64k (or Select Flash RAM, tried both)

Open Myriad GUI

Open Communication Settings

Choose USB(already choosen actually)

Register Test ( Fails all tests)

Picture of the board:




I think, you might have a problem with the firmware for USB microcontroller. Could you download the latest firmware, install them and repeat the register test. The latest firmware you can download from the link below:


This firmware caused the register test to hang ( the GUI showed the register test results window, but nothing was ever displayed in it and windows says application not responding.). The GUI also took longer to load.

I emailed my says rep and he said I should remove resistors R48, R56, R51, R46, R52. what do you think?

Depends, if you are using FPGA (DE0-Nano) together and SPI is establish via FPGA then yes, you have to. The firmware, I linked to it earlier, establish SPI via the SPI to I2C converter (U11). So no need to remove the registers.

Just give a try again, the SPI communication is a bit slow via U11. Because inverter introduce some delay.

Hello all

I have one rf-myriad board, one digital interface board and one de0-nano board

Using firmware 1.06 with and without my de0-nano board I cannot pass register test; all failed.

Using firmware 1.07 and not using the fpga I can pass register test an test the rf board using an spectrum analyzer and a signal generator. The software I have used is crt_6002dr2 version 02.18122012_1330 from the arduino project. Version 02.30102012_1200 doesn’t work. It hangs when running register test.

So here it goes the question. If I want to use the fpga board to transmit and receive data what should I do?

I think I have to delete the i2c_spi_memc from the project beacuse it is useless with 1.07 firm. Do you have an example using de0-nano and 1.07 firm?

Thanks In Advance


Hi ejimenez,

Yes, the FPGA pins for SPI lines have to be set to tristate. Try new files for FPGA below:

Updated firmware for cypress:

let us know if that helps


Hello andrewhux

I have flashed firm 1.08 and it seems to work ok. Both register and basic tests are ok (lo leakage and rx )

I have put the de0 board into its socket and flashed the epcs16 using your file but I don’t see anything “new” on the SA screen What should the fpga board do? Can you provide the fpga full project?

Thanks in advance


Hi ejimenez,

I don’t have in a front of the project file in front of at the moment. You can have a use of project file shared in MyriadRF website:

You can try another file for FPGA. This should generate CW: