V1.4 update failed, stuck on cypress bootloader


I’ve received my v1.4 board and tried to update it after getting the “gateware version mismatch” error message. The update in LimeSuiteGUI failed, but I didn’t record the exact error message I received. Now the board presents with the Cypress bootloader (04b4:00f3).

I’ve tried following Zack’s instructions in the LimUtil --update scrogged - how to start over? thread with both the linked firmware image from github and LimeSDR-USB_HW_1.3_r3.0.img. The “Firmware to RAM” stage completes fine, and I then see the OpenMoko USB device (1d50:6108).

Attempting to program “Firmware to Flash” in LimeSuiteGUI fails with an unhelpful “Programming failed!” popup. If I run the “Firmware to RAM” stage in LimeSuiteGUI (so I have the OpenMoko device visible) and then try to program the flash with “sudo LimeUtil --fw=LimeSDR-USB_HW_1.3_r3.0.img” I get this output:

Connected to [USB 3.0 (LimeSDR-USB), media=USB, module=STREAM, addr=1d50:6108, serial=0009060B00462716]
Estimated reference clock 30.7195 MHz
Selected reference clock 30.720 MHz
[  7%] 12512/186040 Bytes Programming failed! Write operation failed
Programming failed! : Programming failed! Write operation failed

with the progress indicator counting up until it barfs out at 7%

Do I have a b0rked board? Is there anything else I can try? How do I get this working?

Hello @russm,

There is a small jumper next to the USB connector on the board which is designated as “FX3 Boot”. Could you double check if it is mounted, please.

the “FX3 Boot” jumper is attached

Could you post a photo with jumper, please.

Where do you see this device?

By the way, do you connect to the board again in the LimeSuite, after firmware is uploaded to the RAM, how it is explained in step 7 in the procedure?

jumper in place: http://m.imgur.com/qiPdasq

I’m running Linux (ubuntu 16.10), using the binaries from the myriadrf ppa. After programming “Firmware to RAM” lsusb shows the cypress device disappears from the USB2 bus and the openmoko device appears on the USB3 bus.

Using LimeSuiteGUI, after programming to RAM, I quit the GUI, run lsusb to confirm the openmoko device is present, re-run LimeSuiteGUI, connect to the device, then try to program “Firmware to flash”

Could you try to re-mount the jumper, please.

I’m in .au, need to sleep now. I’ll remove the board from case, reseat jumper, and run through the reflash process again in the morning.

What time zone are you guys? ~UTC?


OK, it’s successfully reflashed now. I removed/reseated the FX3 BOOT jumper, and used a different power supply (both genuine Apple USB power bricks, so I’d think they’re good, but shrug who knows).


Note please, that external power supply voltage must be minimum 6V (max 12V). So, if you used USB power brick I would expect it to be 5V which is not going to work.

I’m using a USB power brick via the extra A connector on the USB cable, not to power the barrel jack (to conserve USB ports on my laptop). I assume this is supported?

Well, then you have two power sources which is not correct I think… I would suggest to connect 2 USB ports from the same PC instead of PC + power brick. Or just use external power supply.

Fair enough, I’ll use 6v external on the barrel jack.

Is the power jack “center positive”? I looked for that info but could not find it. I could not read the schdoc files but I guess the info might be in them.

Yep, center positive. It’s silkscreened on the board between the barrel jack and the adjacent mounting screw hole.