Using firmware_v1r08


I do not want to use NANO FPGA board and do not want to remove R51, R46, R52, R48 and R56 resistors from the interface board.

In theory, it is possible with firmware_v1r08.

Is it working?
Would you please send the basic steps for firmware_v1r08?

Bora Dikmen

P.S.: I am using XP SP2 and no driver issues with Cypress USB or NANO board USB. Both seem to work perfectly. But since I did not remove the resistors, it fails in register test.

On the other hand, it can read the register values in the PC GUI program. How could it possible?

Hi Bora,

If you are using firmware_v1r08, the SPI interface will be configured via the Cypress chip. You don’t need the FPGA for that. Download the latest firmware from link below:

Follow the Chapter 4 in the MyriadRF Manual Guide. You can skip the Chapter 4.3 because you do not use FPGA. Download document from link below:

Hi Andrew,

I updated the firmware successfully by first doing the steps in

“4.2.3. Downloading firmware to the not empty EEPROM”

and then steps in

“4.2.2. Downloading firmware to the empty EEPROM”.

But, this time I can not read any register value by means of PC GUI and “register test” stuck.

On power up, EEPROM should be uploaded to the Cypress USB chip because J5 is short.

I can see the “Cypress USB Generic Driver (” in the device manager.
Although everything seem to be OK, I can not read any register and can not perform the register test.

I tried with both NANO FPGA board is stacked and not stacked. I did not program it.

I think, it is related with the “communications settings” in the GUI.
There are only two COM ports, COM1 and COM2.

It is in the COM radio button, either gives 0x00 in “register test”.
It is in the USB radio button, either stuck in “register test”.

I am using XP SP2 over VMware. My basic OS is Win7 64-bit.

What you suggest me?

Kind regards,

By the way,
I had already tried my Win7 Home edition.
I stuck on the driver signature problem.
I tried to bypass it via F8 during Win7 boot;

But, there is no menu to bypass it. May be due to home edition.

Hi Bora,

Try couple links below to load unsigned drivers:

You may need to update your Windows:

As for GUI, use always COM setting and select correct COM port. You can find the dedicated COM port for board in “device manager”. If GUI does not see it:

  1. Close GUI
  2. Unplug USB cable from the board
  3. Plug the USB cable to the board
  4. Run GUI.

It should work.


Hi Adrew,

It is almost like a bad joke that;

1-) HKEY_LOCAL_MACHINE\Software\Microsoft\Driver Signing was already 0x00

2-) In my computer KB2506014 had already been updated since 31 Aug 2011.

3-) I downloaded and installed EasyBCD 2.2. and on its “Advanced Tab”, I checked;

“Allow use of unsigned drivers on 64-Bit Windows”

Then, “Save Settings” and reboot my computer.

Now I can see the “Cypress USB Generic Driver (” under the USB devices in Device Manager.

In its properties, it is seen as; Port_#0002.Hub_#0004

But there is a yellow “!” mark on it, because of warning; “… no digital signature, code 52”.

GUI sees it as COM Port 4 but “register test” reads all 0x00. I never set the radio button to USB side and CyControl.exe utility from Cypress does not see any USB.

I tried your procedure many times;

  1. Close GUI
  2. Unplug USB cable from the board
  3. Plug the USB cable to the board
  4. Run GUI.
    But it never worked.
    How about the +5V external power. I tried to give power after USB cable, before USB cable. But nothing changed.
    I also tried all the SPI speeds but no response.


This time, I tried it with a different computer, Win7 32-bit.
There is no driver signature problem with Win7 32-bit.

I can see the “Cypress USB Generic Driver (” under the USB devices in Device Manager.
But GUI can not see any COM driver.

So, I failed again. I many times tried to remove the USB cable, power off/on cycle etc. But no COM port is available in COM tab of the GUI.

Different from 64-bit, Cypress utility can see “Cypress USB Generic Driver (”.

Motilito mention about his addition of PID DE02 addition to USB driver.
I do not know how to add it?

Is there any update of the driver or GUI?
I am using your latest update;

Kind regards,


Try to run GUI under as administrator user, right click on GUI select “run as administrator”. After this you should see the COM port with GUI.