Update Firmware for LimeSDR v1.4 under windows

Just receive my LimeSDR board , my firmware is version 2 , I try to update to version 3 according guide from @Zack at LimUtil --update scrogged - how to start over? but It still say “Programming fail” . After that I download pothosSDR and run LimeSuiteGUI from Pothos using MANUAL programming it still “Programming Fail” .
After try and error I discover on windows to upgrade firmware you MUST use LimeSuiteGUI from PothosSDR and MUST set programming firmware at Automatic as this picture

The Programming firmware only work with Automatic , using manual it will say “Programming fail”

@sdr_research, I changed from device automatic to manual for each device and it worked OK… The automatic kept trying to drag down the previous version.

Paul - NN4F

With me if I set manual it say “Programming fail” , It take me 1 hour to find out let it run automatic it will update from FW 2 ver 2 to FW ver 3, of course your computer should be connect to internet

I am encountering similar problems to others on restoring the firmware. I accidentally interrupted a LimeUtil --update and the LimeSDR board stopped responding as a LimeSDR board. I followed the instructions to FX3 reset it and the device was recognized as a Westbridge USB device. I was able to connect to it using the LimeSuite GUI that comes with the PothosSDR install and I downloaded the recommended debug image “LimeSDR-USB_fx3_fw.img”. I have tried to reprogram the FX3 image to Ram as suggested however I always get a programming error error message without any other clues. The board is externally powered and was running over the last few days without incident. Does anyone have ideas on what I could be missing?


Hi @rene,

If you got an interrupt during the FX3 firmware update, then you have to use Cypress tools to program it. Refer to sections 5 and 5.2 from this resource to update the firmware. Download the latest firmware here.

Thanks Zack - despite warnings about the documentation being out of date at the resource link, the Cypress tools allowed me to restore my unit. I programmed the suggested firmware into RAM at which point it was again recognized as a LimeUSB device (instead of Westbridge). I then ran “LimeUtil --update” just to be sure that the correct version was programmed to flash memory.
Question: Am I correct in assuming that the .img file is programmed into the usb chip while the rbf file is programmed into the FPGA? The reason I ask is that we need to add some code to the FPGA and I just want to make sure that only that firmware needs to be modified.

Hi @rene,

Glad to hear you restored it!


Hi Zack,
It looks like the CyControl.exe doesn’t work under win10 anymore =>
When i start this program i can’t see any device at all
I use the CyControl.exe from the cy_ssusbsuite_v1.3.3.zip because that’s the only one i can find on the cypress site.
What could be wrong here ? I triedwith and without the jumper.
I am helping a friend because he have some firmware problems and i think he had bricked the flash and i try to recover this.
The PCB is a 1.4s version.

Indeed Ben…the USB Control Center program cannot detect my USB 3.0 connected LimeSDR…
Thanks the help so far. Hope Zack comes with a solution to save my LimeSDR !

Thanks to all beforehand in contributing to the solution to my problem !

Please note in the end the problem on my Board as indicated by Ben (PE2BEN) has been solved.Turned out I had an empty USB3 flash caused by a trial to update the Cypres USB3.0 software (after the selftest kept freezing after one second decided to try this option…Now I know it is a problem with a USB 3.0 port that is probably 1st generation and needs serious update) only to get back an "upload failed"and being sent back to the (in)famous Westbridge 2.0 USB status.

Finally managed to find the correct Cypress driver (Cypress USB Bootloader via “Let me pick from a list etc” in WIN10 updatedriver) in package cy_ssusbsuite_v1.3.3.zip that was recognized by the Cypress Program “CyControl.exe”.
Followed instructions in LimeSDR-USB User Guide called Chapter 5 Flashing the USB 3.0 microcontroller.
For updating the FX3 firmware please follow the Lime Suite documentation instead and execute : To install updated or custom firmware on the FX3 USB 3.0 microcontroller, first download and extract the “CyControl.exe” application from the cy_ssusbsuite_vn.n.n.zip package. Cypress FX3 USB microcontroller has an integrated boot loader, which starts automatically after power-up or reset. If the flash memory is empty or connector J13 on the LimeSDR-USB is open, the USB 3.0 microcontroller boots with the factory default firmware. Run the “USB Control Center” application on the host PC and in the menu click “Cypress USB BootLoader”.
After that I again flashed my Lime with the correct image, reinstalled the Windows drivers and reprogrammed via Modules > Programming > Automatic Updates all the correct software. (using of course the latest LimeSuiteGui).
Using the LimeSDR now in Console V3 where it keeps freezing but this another Lime challenge to tackle HI
PS Also struggled with a faulty jumper J17 FX3Boot that turned out to be all…plastic somewhere having lost the inner metal part guess…Seen in the Forum that I wasn’t the first person suffering from this.

Something similar happened to me, the solution was
Run 5.2 Uploading firmware to empty flash from LimeSDR-USB User Guide - Myriad-RF Wiki page
and then unplug and plug LimeSDR and then run the LimeUtil --update command from a terminal.