OpenAirInterface configuration


#42

Another topic…

It seems that the lms_lib.cpp doesn’t support MIMO yet. Is it correct – any plan/development for supporting it?

Thank you,

–tak


#43

HI, just working on a project and hit this same error. Has this been resolved within the apt install approach ? Also wondering where the mentioned detailed guide can be found for LMSSDR for openairinterface .


#44

Hi,
I have tried to follow the instructions that Andrewback has suggested. Also, Joey’s comments on the cmake_targets/tools/fix_asn1 patch file was also helpful. But the compilation fails for the same error as @Practicing and @brian have mentioned.

'CMakeFiles/oai_lmssdrdevif.dir/openairinterface5g/targets/ARCH/LMSSDR/USERSPACE/LIB/lms_lib.cpp.o
/openairinterface5g/targets/ARCH/LMSSDR/USERSPACE/LIB/lms_lib.cpp:39:28:
fatal error: lime/LimeSuite.h: No such file or directory
#include <lime/LimeSuite.h>
^
compilation terminated.
make[3]: *** ’

Any suggestion on how to resolve it?

Thanks,
Moshiur


#45

The issue you have stems from using precompiled Lime drives via “sudo apt-get install limesuite”. This precompiled version lacks file headers for some reason so the automated OAI builder can find the files. remove the files with “sudo apt-get remove application” then reinstall the files from source. The new files should have headers and OAI should build


#46

Thank you Matt. Yes, we have resolved the issue by compiling the LMSSDR from source.


#47

If using packages and building software that links with Lime Suite, also install: liblimesuite and liblimesuite-dev .


#48

Hi ,
i build and run eNB with the help of this topic and this blog post : https://open-cells.com/index.php/2017/08/22/all-in-one-openairinterface-august-22nd/

I change tx_gain in file enb.band7.tm1.50PRB.lmssdr.conf and every thing seems work properly but my phone can’t see the network .
i use LTE sim for local operator , and my phone support LTE band 7 .

what is the problem , must i use an especial sim ??


#49

Someone on this thread with experience may be able to comment, but failing which I’d suggest posting to the OpenAirInterface community.


#50

Experiencing the same problem now, did you find a solution?

I am using a PCTEL scanner device so I am not bound to having a SIM. The scanner detects the raise in energy but is unable to decode anything on that channel.


#51

Hi , first of all make sure your phone support that LTE band .
My problem solved , i used MNC and MCC code exactly the same as my sim card operator , i changed that to some thing different and it works .
Now i can see the network but i can’t register on that , which is normal . Unlike GSM , registration on LTE network need blank LTE sim card , and sim card writer for writing some parameters in sim card .


#52

I got closer to a working setup by increasing tx gain and the scanner sometimes decodes RSRP, RSRP and CINR but it also appears to loose synch to the cell. Over a period of 30 seconds I get quite good measurements part of the time, bad measurements part of the time and no measurements at all part of the time. Over the course of one hour it was only able to succesfully receive and decode one MIB. A UE can sometimes detect the NW, but without a proper SIM it cannot of course register on the found NW/cell. The scanner has no problems with the live commercial networks and their cells.

The PC has p_states, c_states, hyperthreading, etc disabled and CPU clock is stable. Running a low-latency kernel on a quite capable CPU. I don’t get any “L” printed in the console


#53

Hi,

@ashtum did you have any luck with running the OAI ?

I am also using the same guide for my setup. It is not clear to me that everything is explained with enb band 7 which is 2680MHz but in the .ini files (\targets\ARCH\LMSSDR) Tx set to 1850MHz and Rx set to 1755MHz. I checked the .ini files by loading into LimeSuiteGUI.

It is not clear to me what is the relation between enb.conf files and .ini files and why the DL freq. is different ?

Any help would be great.

Regards,
Ubaid


#54

Hi,
Yes , finally i could see the network in my phone .
Freq setting in .conf file is just matter . my problem was that i used MNC and MCC like my LTE sim card which make my LTE BTS name invisible in search list . When i change MNC and MCC to some thing different it’s name appear in found networks .
Unfortunately i have removed files but as far as i can remember i did’t change any settings except tx_gain .


#55

Reading available sources I am bit confused regarding status of OpenAirInterface
functionality on LimeSDR:…

Blockquote http://www.openairinterface.org/?news=openairinterface-works-with-limesdr

Blockquote https://open-cells.com/index.php/2017/08/22/all-in-one-openairinterface-august-22nd/

Blockquote https://open-cells.com/index.php/2017/05/10/limesdr-installation/

@Laurent Can you please let us know, what is actual status ?
BRG
Djani


#56

I want to ask if it’s available to add new interface to PGW in OAI like S2a,S2b or S2c interfaces.
how to edit PGW config. ? and if that will affect the system we it run or built on ubuntu ?
that’s bec. I want to connect PGW of OAI to a Mobility Gatway


#57

This sounds like a good question for the OAI list/forums.


#58

I made a new set of measurements with a R&S analyzer:
https://open-cells.com/index.php/2018/05/04/limesdr-new-set-of-tests/

My results is that the LimeSDR driver is still not stable and usable, on Tx, and probably also on Rx
Also, the Lime .ini file is mandatory: even calling all available setting and calibration functions on the API is not enough to run correctly a LimeSDR.

There is no explanations on how to build such .ini file.

I’ve put more details on the results:
https://open-cells.com/index.php/2018/05/04/limesdr-new-set-of-tests/

details on the calls to the limeSDR API to try to setup a correct configuration:

I don’t think LimeSDR is working fine: with a good ini file, in specific band and frequency, one may reach a RF communication, BUT too many problems are still existing (see this blog other reports).


#59

Hello,

I’m trying OpenAirInterface with limesdrMini , i use the configuration file : https://sdr-radio.groups.io/g/main/attachment/40140/0/LimeSDRMini.ini that i see on the website : https://sdr-radio.groups.io/g/main/topic/kit_limesdr_march_24th/16180456?p=Created,,,20,2,0,0::recentpostdate%2Fsticky,,,20,2,0,16180456 . when i run the command lte-softmodem i have this error like on this image :


When i stopped the program lte-softmodem, i have this prompt :

Any advise for resolving the problem is very welcome.

Chears,


#60

I got the same problem (Stuck on “[EMU][N]Waiting for eNB application to be ready…”), please how did you resolve it ???


#61

it run perfectly now, please follow the tutorial of Bastien on https://bastienbaranoff.wordpress.com/2018/10/23/openairinterface-4g-lte-with-limesdr_mini/