OpenAirInterface configuration


#22

Hi Joey,

Thanks for the quick reply.

I think I’m already in the 10MHz, at least it says so on the Samsung Galaxy S5 Mobile. On the mobile they have SNR of 20-25. I will try to get the RSSI from the mobile and put it here, may have to wait until Tuesday because I’m working at another location now.

You have valid troubleshooting questions, no offence taken and I was planning to go through them but ran out of time last night.

An additional question, are you using a duplexer with active or passive antenna? I’m using the antenna provided on the CrowdFunding website but I’m aware of OAI mentioning the duplexer. I have a background network on band 7 also because the mobile camps on another network when I’m far from my eNodeB or is not running.

Thanks for your help, really grateful.

Frederic.


#23

Hi Frederic,

We use a Telmat Industries passive duplexer. We got it from a link on the OAI wiki. Emailed a dude named José, he was helpful, took about 3 weeks.


#24

Hi,

Shoudl I just remove NativeInteger.c and constr_SET_OF.c from cloned repository to get it complied?


#25

Ok, I just commented them out from fixasn1. It has compiled.


#26

OK, I was able to start lte-softmodem. I have got it looping for eNB application to be ready.
Does it mean that eNB was waiting for MME connection? I have not setup EPC yet…

"Creating te_thread
[PHY][I]thread te created id=3795waiting for sync (eNB_thread_single)
[HW][I][SCHED][eNB] eNB_thread_prach started on CPU 1 TID 3796, sched_policy = SCHED_FIFO , priority = 99, CPU Affinity= CPU_0 CPU_1 CPU_2
[HW][I][SCHED][eNB] eNB_thread_synch started on CPU 1 TID 3797, sched_policy = SCHED_FIFO , priority = 99, CPU Affinity= CPU_0 CPU_1 CPU_2
waiting for sync (eNB_thread_synch)
Setting eNB buffer to all-RX
Sending sync to all threads
TYPE TO TERMINATE
Entering ITTI signals handler
got sync (eNB_thread_single)
got sync (eNB_thread_synch)
Waiting for eNB application to be ready …@


#27

I believe so Roman. Once you have EPC up, eNB will go farther and may encounter errors later on, but so far it looks like the app is running.

EDIT

I just looked, looks like with my EPC up, my eNB connects to LimeSDR right after the bottom of your log above. So perhaps it doesn’t connect to radio unless EPC is found.


#28

Great! Your reply is inspiring! Now I should spend one more night to setup EPC.


#29

Hi Joey,

I did some tests again later today and they are now fine. I think this is due to me being in a university and some other researchers are using the same band. Probably need to send a broadcast email to coordinate our experiments.

How did your 10Mhz tests go? Any pointers. I want to do them also.

Thank you,
Frederic.


#30

Hi Joey,

Forgot to ask is your setup stable for:
(i) connecting and disconnecting, e.g. put the device in flight mode and then off, mine seem to crash?
(ii) have you tried any handovers?

10 Mhz doesn’t see to be stable for me, crashes all the time during speed tests.

Thanks,
Frederic


#31

Hi Frederic,

By stable I mainly meant a UE can attach and be used for hours without losing connection or things crashing.

When we do this, we may run one or two speed tests, but mostly just use the UE for work, email, web browsing, etc.

We have connected and disconnected a handful of times in a single boot of processes. Some portion of these fail, I haven’t been tracking an exact count. Once it fails, we have to bounce the MME and eNB processes.

Current best guess is a bad state gets stuck somewhere in the MME. We are looking into it. If we find anything we’ll contribute to the project.

We are trying 10MHz this week. Got a little distracted there once things “worked” for a little.

We will not be trying handovers. I was not under the impression that worked. Do you mean X2 or S10 handovers?


#32

Hi Joey,

Thanks for the email.

I think it is S1 handover since I don’t think my eNodeBs will be connected together. I need to spend more time on that but unfortunately I have been doing some virtualisation work for the OAI components.

For the 10Mhz band, I think it is just the eNodeB PC because the eNode process uses 100% of the CPU sometimes. It’s awkward because I guess if I want to connect multiple users etc, I will need a super powerful PC. Have you tried with multiple UEs/mobiles? . I have asked the procurement team to look into the eNodeB options given by OAI. You said you had some issues with Gigabyte one?

Thanks,
Frederic.


#33

Is there anything could be done in the LimeSDR FPGA (h/w accelerators for LTE) to offload the PC host?


#34

Hi Andrew,

I think it is a good idea but unfortunately I don’t have much experience in radio and FPGA so will have to wait for other people in the community.

Thank you,
Frederic.


#35

Hi Frederic.

I’m a little behind on the thread so one by one.

We have had three UEs on at once casually surfing with no issue. Samsung S7, Moto 4G, and HUAWEI 593-22s.

Our gigabyte order round 1 was for intel i7 5775 cpus. There is a known bug with that CPU and the 3.19 kernel. End result, they kernel panic randomly and reboot. Super annoying. We’ve actually seen with with the 4.7.2 kernel too. So… maybe they just suck.

We ordered the same machine with i7 6500 and so far it has been more stable.

We have found i7 with 8GB of ram has been sufficient for us so far. Including 10mhz operation. Though some UEs do better than others at 10mhz.

We have been patching our master branch EPC with key commits from Anoop on the fixed-broadband branch. His base was really old so we aren’t having great luck using the branch as is. He is working on merging with something more recent, but in the interim, we are cherry picking.

We are shooting for stability where a UE can join and rejoin over and over without cratering any processes, mainly MME. I think once Anoop has finished his merge mission it will be a real solid EPC branch… whether it’s master or develop or something else.

That’s where we are.


#36

Hello Joey, I am facing the same problem as you (the RIV_max issue). I didn’t get how did you solve it. Was it the configuration file or you changed the PC? Do you know the main cause of this problem?

Please help me to get through it.

Thanks in advance!


#37

Hi Yaya,

The rf-config file change from comment 14 above fixed that issue for us.

Use

--rf-config-file = LimeSDR_above_1p8GHz.ini

instead of

--rf-config-file = LimeSDR_above_1p8GHz**_1v4**.ini

#38

Thanks for the clarification. I will do that and see how it goes. I will also follow your advice and try to update the EPC side since it is too fragile as is.


#39

FYI, we have found latest CN (EPC) develop branch is much more stable for us. Note that fixed-broadband branch was renamed to develop in the last week. So I suggest a fresh checkout if you haven’t recently.

Also, for lime users (i.e. this forum) the eNB code on develop has been updated and now is performing stably for us. So we are no longer using calib-LimeSDR, we have switched to develop there too.


#40

Hi,

Joey and I have been using this wiring (TX1_2 and RX1_H) for a couple of months and it has been working okay.

I am experimenting with the LimeSuite API (LMS_* functions) this week and found an interesting thing: lte-softmodem is listening to RX1_L rather than RX1_H. That’s what LMS_GetAntenna says (returns 2, which is the index to RX1_L).

I moved the uplink antenna to RX1_L (the second port in the bottom row), and SpeedTest upload went up to about 8 Mbps from 1 Mbps. Disconnecting the antenna still gets about 1 Mbps, so basically we have lived without an unlink antenna for two months (!)

ARCH/LMSSDR/…/lms_lib.cpp has a commented line that forces to use RX1_H, but uncommenting it crashes lte-softmodem.

Has anyone seen this, or is this just happening to us?

Thanks,

–tak


#41

I have some old SpeedTest results with fast upload results, so I’m wondering if this RX1_L/H confusion could be from the 2.8 firmware (02-Apr-2017). I do remember that I used to run the 2.6 firmware.

–tak


Does lms_lib.cpp for OAI support selecting the external clock on the LimeSDR?