LimeSDR - USB3 - Woes - Solved

Good day

I received my LimeSDR v1.4s yesterday and have been trying to get it to work.

First I noticed the one capacitor C410 was broken off on the track, I could fix this easily if the track was still there ;/

Secondly I cannot seem to get it to connect over USB 3.

If I plug it into USB 2 however I can connect fine and run self test, which work fine I might add.

Shall I compose a mail to ask for a replacement?
Kind Regards

I ran the LimeUtil --update command and now I get the following output ;/

Did I brick the Lime?

If it arrived like this I would suggest contacting Crowd Supply to arrange for a replacement.

I don’t think so, since LimeUtil finds it. Can you still run the self test via Lime Suite?

Note that some people have experienced issues with certain USB 3.0 chipsets, which have been resolved by using another computer / USB 3.0 interface. Seems USB 3.0 can be tricky like this.

I have contacted them for a replacement thanks.

This is the output I receive when trying to connect with LimeSuite.

I cannot Initiate the LimeSDR anymore, so I cannot run the test.

This was before running the LimeUtil --update

: USB disconnect, device number 4
: new high-speed USB device number 5 using ehci-pci
: New USB device found, idVendor=1d50, idProduct=6108
: New USB device strings: Mfr=1, Product=2, SerialNumber=3
: Product: LimeSDR-USB
: Manufacturer: Myriad-RF
SerialNumber: 0009060B0046210F

This is after the LimeUtil --update failed.

: new high-speed USB device number 3 using xhci_hcd
: New USB device found, idVendor=04b4, idProduct=00f3
: New USB device strings: Mfr=1, Product=2, SerialNumber=3
: Product: WestBridge
: Manufacturer: Cypress
: SerialNumber: 0000000004BE

im trying the following solution to get the FX3 controller flashed properly.

I got it back to its normal state.

The capacitor is still out of place but all the software works.

That’s good to hear! (apart from the cap and down to you as to whether you swap out via Crowd Supply).

I ran the self tests again.

Seems to be working fine :slight_smile:

I want to try and repair the capacitor, but I am reluctant to tamper with it before crowd supply replies :smile:


C410 is filter cap for IC34 so depends what side is connected it polarized cap.

1 Like

So it is normal for the contact close to the IC to be connected to the capacitor and the other side of the cap to be disconnected?

As the example in the first picture?

Thanks for your input :slight_smile:

@Psynosaur closes to ic is better for rf filtering depends on value of the cap but mostly its .01 uf for filtering rf just to minimize the noise on the equipment if not so military or medical type equipment i will not pass at the quality control off course .

I asked in an updated mail for a replacement unit with no modifications.

My HF modified unit has MN26(T5) removed and not MN18(T3) as per the crowd supply article.

Thanks for all the inputs on the device so far.


You don’t need a pad as it is connected to a ground plane on the busted off side. Just scratch some of the masking around the pad to expose some copper. Bigger the blob the better the job! :smiley:

1 Like

@KBBF5 Hah hah, what a man :smiley: Thanks, I am still awaiting response from crowd supply with regards to the RX1_W port being modified and not RX1_L as specified, for Easyfix 1.


I think that the decision was made by Lime to change the port “At this point it looks as though the HF mod will involve the inductor being removed from RX1_W.”

1 Like

hah hah, i some how missed that…

thanks for the clarification :slight_smile:

I had to put in a spare USB 3 PCI-E(Vantec UGT-PC341) I had lying around, the USB3’s on my Asus Rampage IV extreme seem to be outdated in Linux to connect properly …

These connect first time and run at full 61.44MSPS without packet losses B-)

The full GSM-900 and 1800 bands are quite something to behold with such a span of spectrum.

53 degrees celcius :slight_smile:

Wifi Speed test with my LG G3 on 2.4Ghz Wifi :smiley:

The USB issue is no more, now to fire up that soldering iron… :microscope:


1 Like

Does anyone have the correct location of the windows 10 drivers. I have followed the links on this thread and the official install instructions and I am not able to get the device recognized in windows 10. I see in in the device manager under usb devices as limesdr-usb
but cannot get it to come up under usb controllers as the documentation says.
also the drives I found list
limeSDR-USB (libusbK) a few times
LimeSDR-USB (libwdi) a few times
LimeSDR-USB version: 6.1.7600.16385 (2/10/2017)
none of them say usb3

any ideas would be of great help.


heya did you install PothoSDR development environment?

“LimeSuite is bundled with the PothoSDR development environment to use supported hardware in an ecosystem of SDR applications like GQRX, Pothos, CubicSDR, and GNU Radio.”

I havent installed it on Win10 yet, Linux seemd easiest…
I will give it a wirl tomorrow and report back.
SDR-Console has been my favourite app for my airspy so far in Windows and it has lime support.

yes I installed the PothoSDR suite. it was the first thing I tried.It does not recognize the board. with the driver it uses.