LimeSDR - USB3 - Woes - Solved

I installed that instead of the default drivers.

I can now connect to LimeSDR in Windows via LimeSuite and Cubic SDR

Go to device manager and replace driver with the downloaded drivers.


SDR Console works…

Midnight Microwaving :slight_smile:

The file you suggested I already had but I tried your set anyway. I tried each driver some set it up as its own listining device manager, or under usb device or under com device. Non installed under usb controller as the documentation suggests. And none of them were recognized by the line suite software.

the date seemed to be 2.10.2017 for the version.

Has anyone set this up under windows 10?


I installed PothosSDR and followed the directions to use device manager and point it at the unzipped folder linked above. It finds the LimeSDR in LimeSuiteGUI and PothosGUI but the other bundled software, like gqrx, doesn’t work.

I cannot seem to get my GQRX running on my Win10 installation too, I use GQRX in Ubuntu :slight_smile:

I have the limeSDR working with latest SDR Console and HDSDR via the ExtIO.dll :slight_smile: on win10

Hope you guys come right.