LimeSDR Operates with LattePanda Win10 64-Bit with SDRAngel


Ladies and Gentlemen may I present to you: The LimeSDR operating on receive on the 30m Shortwave Band using SDRAngel running on a Windows 10, 64-bit, 4G (RAM) 64G (FLASH) operating at 1.8 GHz on a LattePanda - - THE SMALLEST FUNCTIONAL WINDOWS 10 PC ON EARTH WITH USB 3.0 RESOURCES…! No kidding, this makes my MSI ‘hockey puck’ PC look monstrous…The LattePanda is slightly smaller in size as my LimeSDR and a VERY POWERFUL little PC, too…I’m INCREDIBLY impressed with this tiny PC…This Single Board Computer also has an integrated Arduino processor and associated GPIO on-board such that all the bandswitching and other functions required to make a Software Defined Transceiver will be very trivial to add-in…The ‘proof of concept’ is complete - - this shows that it CAN BE DONE to make the LimeSDR into a compact, wideband Software Defined Transceiver that can be run on a car battery if needed…Watch the video and see for yourself - the Youtube video is here below:

73 de Marty, KN0CK

LimeSDR as a Amateur Radio Transciever

…And now a NEW video of the LimeSDR connected to the LattePanda Win10, 64-bit microPC with the LattePanda 7" LCD and Capacitive Touchscreen interface connected as well…This configuration will be used as the basis for my LimeSDR HF/VHF/UHF Amateur Radio transceiver. @F4EXB, @brendanthebig, @andrewback, @9a4db Check this one out…Click the YouTube link below to view that video I took yesterday morning…!


73 de Marty, KN0CK


You’re famous, Marty :smiley:


@andrewback - Andrew,

Yep…Carl is real good to me when he sniffs out the news on Lime…I hope that story gets others motivated to so what I’ve done with the LattePanda because it rocks with the LimeSDR and is a natural extension for making a REAL nice transceiver. Thanks for the heads-up, Andrew…!

73 de Marty, KN0CK



I envy you the way you use limesdr as transceiver very much. I tried the latest version of SDR angel and the latest firmware of limesdr in the win10,64-bit operating system environment, but SDR angel never made a sound. Although the received signal can be seen from the spectrum waterfall, but can not choose the sound card in the audio preference option, I wonder why? I’ve tried it on two laptop computers, and the result is the same.
And I had also test the LimeSDR with SDR Console V3.0, but the transmit button is unusable.
Thanks for any advice.



Thanks for the kind words - greatly appreciated. There is a menu bar item (top of the SDRAngel GUI) for Audio Preferences. It’s there that you can select the audio source for the application. Please look for that and then set your audio preferences to your PC’s audio and you’ll be set - you’ll start hearing what you see in the waterfall.

Let us know your progress - thanks,

73 de Marty, KN0CK



Thanks for the reply!
I‘d chosen the sound card several times through the audio preference, but it never works. Every time after the operation, the audio preference menu remains the default option.
Is it possible that SDRAngel has some special requirements for sound card?




I’ve seen that before, too, but I think it’s just because the checkmark was applied but not saved when the form is closed. I would think @F4EXB Edouard may have some light to shed on this issue.

@F4EXB - Edouard: What would cause an audio preference not to be saved in SDRAngel for Win 10? @bh1hxx is having an issue and not hearing anything from SDRAngel - may also affect his transmit audio settings, too. Can you advise on this?

Hope this helps - Stay tuned,

73 de Marty, KN0CK


Thanks a lot.
I’ve just test it on another pc with win7 32bit system and got the same result.




I have a ping out to the author of the SW to see if he can sort this out - In the meantime I’ll do some checking, too…Stay tuned…

73 de Marty, KN0CK



This is a pretty long thread, but it does address how to get the audio working in both Linux and Windows for the SDRAngel. For the time being, check this thread out ----> SDRAngel Rx & Tx

…and we’ll also see if Edouard responds, too. Stay tuned…

73 de Marty, KN0CK


Please read the documentation. You do not select the audio output via the audio preference dialog. This is can be selected per plugin usually by right clicking on the “mute” button. Details may be found in each plugin documentation.

Best regards, Edouard.


@F4EXB - Edouard,

I recall seeing documentation for Linux distros, but not for Win10 (or it didn’t have a heading). Can you provide the link that shows the detail for Win10 for @bh1hxx?

Many thanks in advance, Edouard,

73 de Marty, KN0CK


This is in the Github repository. The links can be found from the Wiki.


Thanks! @martywittrock @F4EXB
I had read some related posts before, but I may have missed something important.
I’ll try.

73 de BH1HXX