LimeSDR Mini with a Odroid H2

I was searching for information what had been done with a LimeSDR Mini and a Beaglebone Black, of which I have several available. Thought it might be a good SBC to pair with a LimeSDR Mini.

Then I read this thread:

As mcbill stated in the OP in that thread, this is also my first post.

After reading mcbill’s thread something with some more power is obviously needed. I looked at the recommended Udoo X86 II Ultra, which seems like an excellent choice, then decided to check to see what else there is available that could be used as well.

I was looking for something with as much RAM and storage as reasonably possible. The Odroid H2 looked like a good candidate.

Key Features

Intel Quad-core processor J4105 (14nm) with 4MiB Cache, up to 2.5Ghz(Single Thread) or 2.3Ghz(Multi Thread)
Dual-channel Memory DDR4-PC19200 (2400MT/s)
Total 32GiB RAM Space with two SO-DIMM slots
4 x PCIe 2.0 for one M.2 NVMe storage
2 x Gbit Ethernet ports
2 x SATA 3.0
SSE4.2 accelerator (SMM, FPU, NX, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, AES)
Intel UHD Graphics 600 (Gen9.5 LP GT1) up to 700Mhz
HDMI 2.0 and DP 1.2 multiple 4K/60Hz video outputs
RTC / BIOS backup battery is included

I ordered one, plus 32 GB RAM and a 256 GB M.2 NVMe drive. I (hopefully) shouldn’t have to mess around with replacing hardware for this project for a while. I bought a few RFSpace UWB antennas but haven’t really put them to use (and have no idea as to whether they perform well). Too many projects, so little time.

Everything should be here within three or four days. I figured I’d design a custom enclosure for the H2 & LimeSDR Mini along with possibly a battery, although I haven’t looked into that yet. That will be a project for my 3D printer.

The H2 looks like quite a powerful platform. I didn’t order one because there was a prolonged shortage of Intel chips which meant they could not be produced.
Instead I got the AtomicPi obviously only has 2GB on board memory. As it’s Intel based, I boot off hard drive an it’s fast compared to e.g the ODROID-C2.

I also have the ODROID-N2 and NanoPi-M4v2 which are no slouches either.

I am thinking of getting the H2 to replace the Atomic Pi.

I’m hoping that the H2 works out. I’ll be setting it up over the weekend. For the time being I decided to do some testing with an Odroid XU4 I bought some time ago. The first go around on the software install from the repo then removing that and then compiling didn’t work. Little quirky things like the focal release was chosen for the ppa repo as opposed to bionic, which is odd as that was an 18.04 release. I haven’t used Ubuntu for the most part in years, and it was 18.04.1 as I recall. I’d upgraded the packages before I started.

Nonetheless, I grabbed the latest Ubuntu 18.04 and installed that, then performed essentially the same steps outlined in the wiki and it worked this time, so I now have a functioning install at this point with all the tests working properly. Ran a RX/TX calibration and it’s ready for me to dig into actually using this thing.

The H2 actually reminds me of the MSI Cubi 2 I have as a quasi desktop here at home. The Cubi 2 has a stronger processor, that being an I5 versus the Celeron on the H2, but other than that they’re very similar boards from a feature standpoint. I had contemplated using the Cubi 2 for this project, but decided that I needed another small computer – 'cause you just can’t have too many.

Received the Odroid H2 and related hardware yesterday. It’s a little larger than I was thinking, although I didn’t look at the dimensions for it when I was considering buying it. It’s 110mm squiare, or roughly 4.4".

Assembled everything, found that the M.2 NVMe SSD isn’t recognized so I pulled the eMMC out of the Odroid XU4 I have and used that. That eMMC wasn’t recognized by Ubuntu 18.04 Server, so I downloaded the latest Debian image (10.2) and installed that. Compiled LimeSuite, SoapySDR and gqrx along with the various dependencies needed short of GNU Radio, which I installed via apt.

I wasn’t able to get gqrx to work on the Ubuntu 18.04/Odroid XU4 combo I used last week to get familiar with the software/setup. Everthing installed was via apt, so no compiling was involved.

gqrx works on the new setup. Oddly, gqrx shows the LimeSDR mini in the pulldown menu for the setup, but it doesn’t work, you have to use Soapy & the connection string. Other than that everything appears to be working fine.

I’m going to go back and see what I can do about figuring out why that M.2 NVMe card doesn’t work. I’d much rather use it than the eMMC storage. It’s not a matter of the OS not recognizing it during the install, the BIOS on the H2 find it.

It’s been this way for some time.

That was the first time I had seen it in the pulldown, although also the first time I had compiled it as well.

After some hardware review, I found the BIOS was recognizing the NVMe SSD. It showed some generic reference which didn’t provide any detail as to what it is. I thought it was part of the menu.

I went through the install regiment again, and compiled everything so I’m pretty much where I was on the original eMMC install. I must have pulled the SSD before I tried to install Debian the first time.

I need to figure out what antennae I should be using.