LimeSDR Mini broken?

Hi there, recently got my LimeSDR mini, and was using it for a while under Linux.

Unfortunately, when I used the LimeUtil --update command, it failed to update.

It gave a 0% output under Linux when trying to flash, and then just died.
I have no red or green lights anymore, and have not found a way to flash it back to life (via software).

I self compiled my own version of LimeSuite under Linux, this did not help at all.
I have tried using images downloaded manually, but alas nothing works.

I eventually got around to using a Windows machine, not a VM, and when I try and use LimeQuickTest to no avail.
Every time I select connect (under Windows) on the LimeSuiteGUI it freezes, until I remove the LimeSDR Mini, same with the quick test tool. When I remove the device, the log is populated with a constant output of “ERROR: Read(64 bytes) failed”

Under Ubuntu 18.04, I get “ERROR: Read(64 bytes) failed” again.

The device is detected by both Windows and Linux but Device Info is not populated, only with 0’s and UNKNOWN.

Will I need to do an FPGA flash over JTAG to recover this, or should I just RMA it…

I have tried most other solutions discussed in other posts, but none have worked so far.

I have made sure that the device has always been in a powered USB 3 port, and displays as such in the GUI and CLI of each software. Even changing Windows machines that stated USB 2 on the connection menu.

The FTDI FT601 USB 3.0 Bridge is still detected under Windows, so I do not think it is that. Some help would be really appreciated.

Also, my board revision is 1.2 if that helps.


Sorry to hear that. I’ve never seen this happen before, but I guess it is possible it may need programming via a JTAG cable. @Zack may have some suggestions before attempting this, though.

I do not have a USB Blaster, but I do have a Open JTAG board which is apparently equipped with an Altera EPM570 MAX II CPLD. Is this sufficient to flash with?

I have no idea. I do know that we didn’t have much luck with those really cheap USB Blaster clones, but @mariocannistra did and I think there is a post where he shared details.

Hi @Shauneh,

It is quite strange, while every board is programmed and tested in the factory. Do you see any LED activity?

If you want to re-program it via JTAG, then you need an adapter cable as described here:

Check this post by @mariocannistra for cheap JTAG programmer:

Hello @andrewback, @Shauneh
I guess you could start reading that thread from this msg: Problems with LimeSDR mini - #118 by mariocannistra

I’m not an expert but I think that I was able to program because the 9 Euro clone that I’ve used was using a micro (STM32…) and was able to find and use a suitable device driver in the Altera forums.

copying some lines from that thread:

I initially had blue screens or Quartus Programmer crashing due to issues with USB Blaster device driver. I was using the one supplied with Quartus standalone programmer but there seems to be some incompatibility with 64bit Windows and/or signatures.

I found another driver in this post on Altera forum: (scroll to message #5 ).

I uninstalled and removed previous driver and installed this one after disabling the windows signature enforcement. Not a best practice but no virus was detected in the downloaded zip file.

Please note that this new driver is FTDI related. I guess the clones emulate FTDI chips using the STM32 micro programmed for this…

Please read all that thread because there are several details about pins layout, how to connect + which files to use with Quartus + how to run the programmer…

I know that feeling when cabling, rechecking and then hitting the button :slight_smile: Good luck and let’s hope you solve it this way.


:smiley: Hello @Zack sorry for the overlap… we were writing at the same time…

1 Like

Hi @Zack

I had it working with LED activity right up until I used the LimeUtil --upgrade command, and then it was dead.

Before hand I had it working in GNU Radio. although I did not test the output as I was just trying compatibility with 18.04 and the new PPA’s.

I will look into reprogramming it to try and bring it back to life, but I do seem to be the only one with this problem so it may be hard to find resources if the guide for the USB Blaster does not go anywhere haha.

Will update everyone soon!