Lime USB not recognized

#1

My LimeSDR USB has stopped being recognized by Windows. It had been flaky from the time I got it - requiring me to plug and unplug multiple times (same on multiple computers) before Windows would sense it. When it did connect, it seemed to behave normally. Now, when I plug it in it shows up as 'Unknown USB Device (link in compliance mode). On my Linux box it shows up in lsusb as ‘OpenMoko Inc’ (?!)

image

When I try to reinstall drivers, Windows tells me that I the best driver is installed ‘Unknown USB Device…’

I’ve only had it for about two months - is there any way to get it going again?

-Scott

#2

Okay, some more information…I’ve learned a lot in the last couple days. First, I now think it’s relevant to point out that this board NEVER connected as USB 3.0, only 2.0. I thought I was probably doing something wrong, though I had verified that my entire chain (PC USB -> Cable -> Lime) was 3.0.

I learned how to program the FX3 Flash using the Cypress tool (Limesuite crashes when I try to use it to do this). The flash memory either fails to program, or will fail to enumerate after programming. I can program the RAM and the board operates normally until a power cycle. I have to conclude that the FX3 flash memory is faulty…unless anyone has any other ideas?

Do I have any recourse for an exchange? As I said, I’ve only had the board for around two months. It took me that long to build my enclosure (which I’m pretty proud of, I have a bias-T in there that I can switch in and out of the RF chain using a Dow-Key Microwave RF switch).

-Scott

#3

Contact CrowdSupply and check if replacement is possible.

#4

I have the same or very similar problem. The board was running for about 2 days. On day 3, windows stopped recognizing the board at all. Not even as “unknown device”.
Am still hoping to find a fix, so I can use the board again.

Manfred

#5

Hi Manfred,

I’ve emailed CrowdSupply, but I really don’t expect an answer from them. They are probably too busy, plus there is really no reason for them to reply - my board is past the 30 day limit.

The FX3 has a JTAG header and I’m looking into making a cable to connect to it (something I’ve had a little experience with years ago). If the issue is the flash chip, it might be able to be replaced, but if the problem is in a trace or on the FX3, there is probably no solution. In the meantime, programming the FX3 RAM will allow Windows to recognize the board again, but it seems like a hack to use a device that was (for me) an expensive purchase.

#6

Hi Scott,
thanks for your reply. I have puchased another gadget, the Adalm Pluto SDR. This works just fine. However, I prefer the concept of the lime sdr - so I will try to get it running again. Currently I am very busy with other things, so I will have to learn on how to reprogram the FX2 RAM and get the needed hardware later the year.
Manfred

#7

What LED activity do you see?

#8

First I should mention, that I do have a LimeSDR-Mini.

The orange LED ist on, as soon as I plug in the USB connection. It is not blinking, just on - no changes

#9

Update - my board has now completely stopped working at all. I can use the Cypress software to flash the FX3-RAM (jumper is removed - and board is recognized as a ‘Cypress FX3 Bootloader Device’), the Cypress software will say programming successful, but the board will never show up again as a ‘LimeSDR-USB’ like it did before. I’ve tried several times and ways to try to get the board to show up, and it just won’t.

Crowd Supply DID get back to me and will determine their course of action based on any troubleshooting that results from these posts. Any further ideas to try are appreciated!

#10

Do you place boot jumper after flash programming back?

#12

@Zack - yes sir, I have tried that.

Steps I’ve taken:
Power off-> remove jumper->power on, board is recognized as …“bootprogrammer device”…->using Cypress USB Control center, I try to program FX3 SPI Flash, the result is “Programming of SPI FLASH erase failed”:

I power cycle again (jumper is still removed), and the board will show up again as ‘bootloader device’, and I choose -> ‘program FX3 RAM’. When I would do this before, the board would immediately show up as a ‘Myriad LimeUSB…’ (something like that - I can’t remember the exact name), and it would operate as normal (jumper still removed) until a power cycle. If I replaced the jumper and then power cycled, it would go back to not being recognized by Windows as in my first post.

Now, when I try programming the RAM, once the programming is complete, it will just sit and not get seen as a USB device. Also, FYI, in some iterations, I have tried rebooting my computer between steps…I didn’t know if that would help - and it didn’t make a difference.

Best regards

#13

Hi @mscottm,

It looks like you are missing one important step. Check sections 3 and 3.1 for more information.

Long story short, the sequence should be as follows:

  1. Power off the board (disconnect it from computer);
  2. Un-mount “FX3 BOOT” (J17) jumper;
  3. Connect the board to USB;
  4. USB control center should show it as “Cypress FX3 USB BootProgrammer Device”. Exactly as in your case;
  5. Mount “FX3 BOOT” (J17) jumper back - that’s the important step;
  6. Now you can program Flash memory.

After this you will not see LimeSDR-USB board via USB Control Center application, while VID/PID pair is changed. Use LimeSuiteGUI instead.

#14

@Zack - thanks for your quick reply!

The first sentence in Section 3.1 states “Short the J17 jumper” - I assume that is your step 5 above? When I follow the sequence as you list, when the programming seems to be complete, after a time, Cypress reports “Cypress boot programmer device not found”. I assume that is, as you say, the device has changed function. When I then open LimeSuite, no device is listed in the Connections dialog:

image

and nothing is seen in my USB device list. If I then power cycle, its the same result.

Best regards

#15

Hi @mscottm,

Correct.

Yes, it is expected.

What LED activity do you see?

Do you see the board in Device Manager?

#16

Hi @Zack,

-What LED activity do you see?
I see two green LED’s (two closest to USB connector) and one flashing red/green (closest to board edge).

-Do you see the board in Device Manager?
No, nothing appears in Device manager until I once again remove the jumper and power cycle.

#17

This is as it should be.

Strange. USB communication is definitely working, while you can program the board. As far as I understand, you have an access to Linux machine too. Could you post lsusb output here, please.

#18

@Zack

My linux box doesn’t have USB 3.0, but when connected via a USB 2.0 cable, lsusb reports:

…snip…
Bus 001 Device 003: ID 1d50:6108 OpenMoko, Inc.

This is the device that appears/disappears when the Lime is connected/disconnected

#19

Yes, this is LimeSDR-USB board.
It looks like you have some issues with driver on your Windows machine.

#20

Hmm, I will look into this.

Just thinking out loud…I know the driver was installed and working correctly, as I was able to use the board for a while. I suppose the driver could have become corrupted? I’ve had no other similar issues with other devices - the PC is stable. Can I use Zadig to re-associate the driver with this device?

Thank you for the time you’ve spent on this issue.

#21

Update - I was able to force the driver to update with the Win10\cyusb3.inf driver file. After the update Windows reports the device is in an error state ‘Compliance’:

I still think this is a hardware issue. Please let me know if you have further thoughts! I really want to get this resolved and start using this board.

Best regards