GRGSM LimeSDR-Mini Ubuntu 18.04 LTS

Am trying to get LimeSdr Mini to work with grgsm_scanner on Ubuntu Server is impossible to install UHD drivers anymore does anymone has an image of working LimeSdr mini with GR-GSM??

Afraid not, but we are working on a version which uses the gr-limesdr blocks so that you don’t need to have UHD and SoapySDR plus plug-ins in the middle.

1 Like

I found an old Iso Image that has all prebuilt already with 16.04 LTS but is ISO and cannot rely on that is there any other way around to SCAN ARFCN with lime SDR? is working perfectly with a old RTL-SDR we bought Lime-SDR to update our system and we can’t manage to get any results it’s such a shame.

I think in theory it should work, but I didn’t have much luck when I tried and there is no point in us investing time in trying to get this working via gr-osmosdr — a route which will always be far more fragile — when there is work to use it via a gr-limesdr source.

Of course, everything is open source and so you are free to debug and fix it yourself :slight_smile:

So the gr-gsm fork here uses gr-limesdr:

It’s just the actual script that was modified, so if you already have a build, you should be able to just drop the modified version in:

Hi again Andrew,

I tried with your methode but still didn’t manage to get limesdr mini with grgsm_scanner. you have any installtion procedure for limesdr mini to work with grgsm_scanner?

When I replace with your file grgsm_scanner, I get the following message:

user@ubuntu:~$ grgsm_scanner
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

Segmentation fault (core dumped)

After some more tried getting:

user@ubuntu:~$ grgsm_scanner
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

Traceback (most recent call last):
File “/usr/local/bin/grgsm_scanner”, line 37, in
import limesdr
ImportError: No module named limesdr

Could that have to do with anyting that Board is Faulty??

You need gr-limesdr blocks installed.

Could u provide some help regarding limessr blocs?

You need to install them, along with gr-gsm and its dependencies. If this doesn’t help, you’ll need to be more specific.

Ok I installed Modules for GNU Radio they appear in GNU RADIO but now when I get the following error:

user@ubuntu:/usr/bin$ grgsm_scanner
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

user@ubuntu:~$ sudo grgsm_livemon
[sudo] password for user:
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
gr-osmosdr v0.1.4-127-g4d83c606 (0.1.5git) gnuradio 3.7.11
built-in source types: file fcd rtl_tcp rfspace soapy redpitaya
linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

[INFO] Make connection: ‘LimeSDR Mini [USB 3.0] 1D40EE3D36AF1C’
[INFO] Reference clock 40.00 MHz
[INFO] Device name: LimeSDR-Mini
[INFO] Reference: 40 MHz
[ERROR] TuneVCO(CGEN) - failed to lock (cmphl!=0)
[ERROR] SetFrequencyCGEN(61.44 MHz) failed
[INFO] LMS7002M calibration values caching Disable
[ERROR] TuneVCO(CGEN) - failed to lock (cmphl!=0)
[ERROR] SetFrequencyCGEN(80 MHz) failed
[ERROR] TuneVCO(CGEN) - failed to lock (cmphl!=0)
[ERROR] SetFrequencyCGEN(256 MHz) failed
[INFO] Selected RX path: LNAW
[WARNING] RXLPF set to 1.400 MHz (requested 0.650 MHz [out of range])
[ERROR] Tune Rx Filter: MCU error 2 (CGEN tune failed)
[ERROR] setBandwidth(Rx, 0, 0.65 MHz) Failed - SetFrequencyCGEN(256 MHz) failed
Traceback (most recent call last):
File “/usr/local/bin/grgsm_livemon”, line 364, in
File “/usr/local/bin/grgsm_livemon”, line 352, in main
tb = top_block_cls(args=options.args, collector=options.collector, collectorport=options.collectorport, fc=options.fc, gain=options.gain, osr=options.osr, ppm=options.ppm, samp_rate=options.samp_rate, serve$
File “/usr/local/bin/grgsm_livemon”, line 118, in init
self.rtlsdr_source_0.set_bandwidth(250e3+abs(shiftoff), 0)
File “/usr/local/lib/python2.7/dist-packages/osmosdr/”, line 1789, in set_bandwidth
return _osmosdr_swig.source_sptr_set_bandwidth(self, bandwidth, chan)
RuntimeError: SetFrequencyCGEN(256 MHz) failed
libusb: warning [libusb_exit] application left some devices open


GRGSM-SCANNER working Thank you very much for your help,

Hi smtguide,

can you remember how you fix the "Tune Rx Filter: MCU error 2 " Error ?