Hi everybody,

I would like to test the Fast Fourier Transform Application.
DE0_Nano_Board is connected and programmed with demo_txcw.sof data.
Register Tests of MyRiad Board are ALL OK.
Never the less whenever I try to start the FFT Software I get an
Access Violation warning popup window.
DO I Have to install the software in any special way or do I have to
put it to an alternative folder?

Thank You very much in advance


Could you more specific on what kind of error you are getting? What OS you are using? Do you change some setting in the FFTviewer?

FFTviewer has to be in the same folder with these files:

Have you downloaded gateware form GitHUb repository?


Thank You Andrew,
My OS is Windows 7 64 Bit Architecture.
I downloaded the Software from “http://myriadrf.org/fast-fourier-transformation-software/”. I only extracted the file and tried to start it.
No I can´t change anything in the FFTviewer because there are constantly
popping up these error messages.

The first error message which pops up only once is: Access violation at address 00000000. Read of address 00000000.

The following two error messages are repeating alternatingly:

  1. Access violation at address 00426204 in module ‘FFT Viewer.exe’. Read of address 0000029C.
    2.1. Access violation at address 004272CA in module ‘FFT Viewer.exe’. Read of address 000000F4.

Hi BigSmoke,

I’v been trying to run the FFTviewer on various platforms and I couldn’t get any errors. Can you try the version I’m using, it looks like in the link you gave me it is older version:

Hi Andrew,
thank you very much.
Your new version starts without any error
messages but now I got another problem. I have access to the LMS6002 Chip via the ctr_6002d Software. All register tests are ok and all settings are applied to the chip. Unfortunately the register test with the fft - software fails and I can´t do anything with this software. DO you have any solutions?
Do I have to copy the folder to another direction?
Because I started the software directly from an USB Storage.

Thank you in advance


Copy FFT software to some folder in your PC. Run FFT software as administrator and select correct COM port in communication settings window. This should solve the issue.


Hi Andrew,
that was exactly what I tried but it didn work.
But wait in an upper comment of yours you suggested to download
the latest version of gateware software for DE0-Nano board.
I tried hard to download the folder gateware but I’m not
able to do so.
I can use both OS Windows and Linux. With Linux do I have
to download the folder with the git command, with ssh or
because it’s an https webpage do I have to do something else.

Thank you for your support.


Hi Robert,

Try to download the same files from dropbox link below:


Hi Andrew,
thank you very much for your answer.

I could download the whole package from github.
I used gateware version of github and of course I
started FFTViewer with administrative rights.

But the problem still remains. When I use FFT-Software
and open Tools > Control Panel I can´t get through the register test
whereas with the ctr_6002d.exe software everthing works well.
Have you any other idea to solve that problem.


Well in Addition:

With GitHub Gateware for the DE0-Nano FPGA ctr_6002d register test also fails…
So register tests are okey if I use gateware version of software bundle of




Ok Robert,

That is getting interesting. When you have downloaded files form GitHub have you used a firmware for Cypres Chip? If not reprogram it, and repeat the test.

Have you done any mods to the boards?


Hi Andrew,

I only removed the resistors which was neccesary because of DE0_Nano_Board.
I did no other modification to the board.

I programmed the Cypress Chip RAM with the v6 version, because I don’t have
use Bypass Mode.

And to answer your question I downloaded the GitHub bundle on Friday 10th of January 2014.

Thank you for your effort!



I think, the problem is that the mods are not compatible with the firmware you are using. Could you do the following steps to prove the point:

  1. Please solder back resistors on DE0-Nani interface board (R52, RR48, R56, R51, and R46).
  2. Program Cypress chip with firmware 8th version (firmware_1v08.iic). Once done, disconnect DE0_Nano board and try to run GUI to Myraid RF registers (run register test). If it pass go to next step.
  3. Connect DE0-Nano Board and program FPGA with firmware downloaded from GitHub.
  4. Run FFTviewer.

Under this setup, SPI interface is controlled from Cypress chip were I think your problem at the moment is.


Thank you Andrew,

I am going to test this configuration.
But one more question came up.
Can you tell me the mapping of the DAC?
So what I would like to test is which bit-Scheme produces
what kind of signal.
Is it mapped with the one’s complement or
with the two’s complement.


Hi Robert,

It is two’s compliment mapping. For both DAC’s and ADC’s.