Windows 8.1 Driver Update Failure

I got my LimeSDR in early December 2017. I built the acrylic case and installed the board, but did not have a USB 3 cable to connect the device to my computer.

This week I finally received the cable and I cannot update the Windows 8.1 x64 default driver to the Myriad driver. This is the error I receive:

If I launch LimeSuiteGUI in Windows and choose Options > Connect, there are no devices in the list. It’s empty as shown here:

I also tried to connect to the LimeSDR in Ubuntu. After installing the PPA and all the software, LimeSuiteGUI does not list anything to connect to in Options > Connect. The screen is empty, same as shown above in Windows 8.1.

I have 2 solid green lights (closest to the USB connector) and 1 red flashing light (closest to the edge of the board, not the inner LED).

I have tried different USB 3 ports with the same results. I tried disabling driver signing, same failure. I also re-downloaded the driver. Same failure.

I’ve searched the forums and it seems like my LimeSDR may be defective. Do I have a defective device? Is there anything else I can try to get this set up?

Hi @bitwiz,

Could you check Device Manager please. Do you see LimeSDR there?
While in Ubuntu, try lsusb command and post the output here.

Yes it shows up in Windows device manager.

Did you follow this tutorial for the driver install?
When the Lime driver is correct, it “Should” show up as “Myriad LimeSDR-USB” or something close.


I was following the tutorial ( for the driver install. When it instructed me to update to the Myriad driver, that’s when I got the first error above about the hash (while I was in Windows).

Here is the output in Ubuntu from lsusb:

Bus 002 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor
Bus 002 Device 003: ID 413c:8194 Dell Computer Corp.
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0c45:648b Microdia Integrated Webcam
Bus 001 Device 004: ID 413c:8197 Dell Computer Corp.
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 1d50:6108 OpenMoko, Inc.
Bus 004 Device 002: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

With the LimeSDR disconnected, the “OpenMoko, Inc.” disappears, so I’m guessing that’s the unit. Is this output correct for the LimeSDR in Ubuntu?

Okay, so I decided to re-clone the git repository for Windows a third time and today it updated without error. I have no idea what’s different between now and a week ago, but the driver is shown properly installed in Windows device manager now.

Screenshots after successful driver update:

Still not sure about getting the LimeSDR working on the Ubuntu side, but if I pursue that, I’ll start a new discussion, though I would like to know if that output from lsusb above is correct. I’m guessing it’s probably fine just by the fact it shows up while connected and disappears when disconnected.