Windows 10 64-bit Driver won't install?

I downloaded the current 32 and 64-bit Windows 10 drivers. My new LimeSDR shows up in Device Manager as “LimeSDR-USB”, which I do see in the inf files. However, when I try to update the driver, I get this message: “Windows could not find driver software for your device”. I’ve tried rebooting, unplugging and reconnecting the LimeSDR, but I always get the same thing (32 and 64-bit).

I also tried the Cypress driver, but it doesn’t have “LimeSDR-USB” listed in the inf file and I didn’t want to mess with it.

Has anyone else experienced this and found a resolution?

Thanks in advance - David Salomon

try the cypress driver …

you could always un-install it …

Did you download a zip file? and did you unzip it? I saw this happen with another ham I helped who was seeing the same thing…


Hi David. Yes, as @N1JEZ points out, you MUST unzip the driver into a folder, not just point the ‘Update Driver’ dialog at the zip file. And dumb question, but there’s no yellow triangle next to LimeSDR-USB in Dev Mgr, right? And it’s under USB devices?

This is what it’s gonna look like when you have it right :slight_smile:

It is not gonna work, do not waste your time. The reason - Cypress driver doesn’t have LimeSDR-USB VID/PID in the inf file. Hence no chance to install it.

I had this problem when trying to install drivers from the repository clone that I created on my local disk. From the archive, the driver installed without problems. I found that the cyusb3.inf files from the archive (14,989 bytes) and the clone are DIFFERENT in size (15,314 bytes) but the same in content. Perhaps the OS is so fragmented cloned cyusb3.inf.


It also can be application specifc, too. Some applications use the Cypress driver, and some applications use the Windows driver that ZADIG (a Windows driver install application) uses. Neither one can be active in Windows at the same time - only one (Cypress that is the native driver for LimeSuite and other applications) or the other (winusb that ZADIG uses and is compatible with SDRAngel and other apps). Again, only one or the other driver can exist for the LimeSDR - but not both at the same time.

Hope this helps - 73 de Marty, KN0CK