Weird Firmware Update Issue

Hey All. It has been a while since I have posted on here. I drug out my Lime SDR the other day to see what improvements have been made in the last year or so. My Lime SDR worked fine, then I decided to update Pothos and also update the Firmware/Image of the Lime SDR.

That is when my issues started. I started getting gateway version mismatches as well as blank revision numbers. I had to go back to an older version of Pothos to recover the device. It simply wouldn’t work with any software I tried.

After much trial and error, It seems as my Lime SDR will not work with the HW_1.4_r4.0 image. It only works with the HW_1.3_r3.0 image. The highest .rbf I can run with this image appears to be HW_1.4_r2.11.

The board that I have is an early crowdsupply backed board, silk screened 1.4s. If anyone has any input or suggestions for me to try, I will do my best to answer any questions. The board does seem to receive alright, I just can’t flash anything newer than the above versions. I did the HF mod on the RX_1L port only(I am a HAM) and Limesuite reports Ver = 7 Rev = 1 Mask = 1.

I forgot to mention that the newer images/firmware just give me read/write errors in LimeSuite and none of the software will connect to it.

Let me know what everyone thinks.


@Zack, could you assist?

Hi @Jman87,

I would suggest to follow section 2 to update USB MCU firmware from
Then follow section 4 from the same link above to update FPGA gateware.
Use LimeSuiteGUI for programming.
Download firmware and gateware here.