Unbutu version for limesdr mini to work OPENBTS?

I’d like to know witch is the best ubuntu version to make work with openbts

It will be more about the versions of the software.

I’m trying all kinds of combinations with no luck. limesdr updated to gw=1.24/fw=5

adm64 16.04 gives:
osmo-trx compiled from source, the rest from ppa:
osmo-trx setp11frequency time busy bit set 1
osmo-trx from nightly builds:
undefined symbol

virtualbox 5.2.10 on win10
osmo-trx compiled from source, the rest from ppa:
UHDSoapyDevice] setBandwidth errror
osmo-trx from nightly builds:
undefined symbol
but now doesnt attach the sdr properly any more. not sure why.

arm64 - compiled from source gives:
UHDSoapyDevice] setBandwidth errror

So, if you find a setup that works, I expect there will be a few people who’d like to know.

1 Like

Try Lime Suite (thus gw + f/w versions also) and OsmoTRX version specified here:

1 Like


that was the config that i was using. it looked to be the best one.

i’ve compiled limsuite 17.12 and osmo-trx 0.3.0 but i still get:
[FATAL] [UHDSoapyDevice] setBandwidth(Tx, 0, 5 MHz) Failed -

the only other weird thing i noticed was that on the mini board the version is 1.1 but that git page talks about 1.4. did crowdsupply send me old h/w or is that for the big brother ? (delivered in April)

i also thought i’d read that the mini was supported in limesuite 18.x ?



That’s right and you have the latest LimeSDR Mini hardware. I’ve just updated the page to clarify.

@cswiger, not sure if you have a Mini and have tried?

I did get the Osmocom stack working with a pre-production Mini some time ago, but a lot will have changed since then and I didn’t note all the software versions used.

In general I’d recommend waiting until around the end of the month when we should have initial support for using Osmocom without UHD and SoapySDR, i.e. direct LMS API integration. This will greatly simplify things and make it easier for the developers to support. We’re aiming towards having the Osmocom stack as pretty much a reference application, stable and well supported. It is possible to get stuff working in the meantime if you’re in a rush, but you’re kind of on your own with a Mini (unless anyone else offers assistance).


Ok, many thanks for the information.

I’ll wait then … the direct connect method will be much better.

Still waiting on a lime-mini delivery.

Meanwhile, since the osmocom conference we see osmo-trx supports a ./configure flag --with-lms that does a pkgconfig search for LimeSuite.pc - investigating.


Yea, after switching to branch laforge/lime it’ll build an osmo-trx-lms that actually works with the latest and greatest LimeSuite 18.

Do you have a complete install script?

this will get the code etc

  git clone -b "laforge/lime" git://git.osmocom.org/osmo-trx
  cd osmo-trx
  autoreconf -fi
  ./confgure --with-lms
  make -j3
  make install

but i get this error when running
osmo-trx-lms -C ~/cellular-network-configs-master/osmocom/osmo-trx-limesdr.cfg
Error in LMS open, closing: TuneVCO(SXR) - VCO too high

close. i can almost hear the phone ringing

1 Like


1 Like