Unable to update driver, Win7 64 bit

Hi all,

Had LimeSDR working with SDR-Console with some issues. Was fiddling around, eventually decided to uninstall windows driver, to install it again, but something went wrong.
LimeSDR is now under Other Devices in Device Manager with a yellow exclamation mark. Properties shows no driver installed. Tried Update driver, pointing at 64 bit W7 driver directory on harddrive gives “your LimeSDR-USB can not be installed”.
Disconnected Lime, restarted computer, connected Lime again, same thing.

Hope someone can help.


Hi @CvR,

Try to uninstall it as described here in first answer (using pnputil).
In my case, when I run pnputil -e, I have:

Published name :            oem98.inf
Driver package provider :   Lime Microsystems
Class :                     Universal Serial Bus controllers
Driver date and version :   08/19/2015
Signer name :               Lime Microsystems Ltd

So, removing in my case would be:
pnputil.exe -d oem98.inf

Then try to install the driver again.

Hi @Zack,

Thanks for your help.
Did the procedure, uninstalled the drivers.
LimeSDR had to be removed first, otherwise pnputil didn’t let me uninstall the drivers.
Attached LimeSDR, tried to install new drivers, no go. See screenshots. Text in Dutch I’m afraid…

Hope you have a plan B for me.

73, Cornel

May be important, may be not. But the drivers from the Wiki LimeSDR-USB User Guide, chapter 4.1 from Cypress are version,the ones in the Github are version
Both do not install.

Just reread my first post, will try to give more detailed info on what happened.
At first setup I installed the USB driver from Cypress as described in LimeSDR-USB User Guide 4.1.
Later updated the drivers with the ones from Github.
Also updated firmware.
LimeSDR worked ok with SDR-Console but the program would freeze when changing bandwidth and other settings.
I noticed that LED 5 FX (USB) status sometimes blinked red instead of steady green, especially just before freezing of the SDR-Console. So suspected the USB 3.0 port to be the problem.
Started fiddling with the drivers, back to the earlier (Cypress) version, no improvement. Uninstalling LimeSDR and installing it again. No improvement.
Somewhere along this path the problem occured.
Could it be that somehow the driver files of different versions got mixed up?

Hi @CvR the User Guide is out-of-date and needs updating. Please follow the Lime Suite documentation instead:


This points to the correct Windows driver. The LimeSDR-USB User Guide still references the old one which uses a different VID and PID.

Thank you, @andrewback! Unfortunately this will not solve the problem. My computer never goes past step 3 :disappointed:

On second thought: it works!
Thank you, @andrewback and @Zack, for your help.

Unfortunately SDR-Console still freezes after a while, but I will take that up via another topic :sunglasses:

Thanks again!


1 Like

That’s good to hear and thanks for letting us know! :slight_smile: