Trouble with GNU radio Tx

Hello everyone, quasi-newbie to LimeSDR here. I am not new to SDR, but somewhat new to LimeSDR. I have had a mini for a while, but recently decided to buy a LimeSDR USB. Any how, I am having trouble with transmitting with GNU radio. I can receive just fine in MIMO mode (I would like to make some coherent phase measurements down the line) however when I add a LimeSDR sink it locks up the FFT in GNU Radio and I only get a DC spike on the output. I have done my best to read though the previous posts, but couldn’t find anything on the topic that helped. I also tried the example grc files that come with gr-limesdr however none of them work, no output. I have also tried a simple MIMO source right to a sink with nothing in between and the same frequency, using a CW sig gen but I get nothing. I can tell the Rx and Tx amps are working because I can see the noise floor go up and down, but nothing else. I am running a newer laptop with Ubuntu 16.04 LTS and GNU radio 3.7.9. Sorry if this is a repeat, any help would be appreciated!

1 Like