Soapy Tools and Ubuntu 16.10

I am getting an error when I try to install Soapy Tools under Ubuntu 16.1, it is a new installation. Should I even worry about Snappy Tools? I get an error:

E: /var/cache/apt/archives/soapysdr-tools_0.5.1-1_amd64.deb: trying to overwrite ‘/usr/bin/SoapySDRUtil’, which is also in package soapysdr 0.5.4-myriadrf1~yakkety

Thanks in advance,
Larry in El Paso

remove the older before install new …

Or try a -f (force)

I wish I had your skills. I am at a loss for what you want me to do. Is there a file I need to remove using Synaptic Package Manager?

Larry in El Paso

what/how are you trying to install Soapy Tools with …?

Is it apt-get or synaptic?

sudo apt-get purge --auto-remove soapysdr
sudo apt-get purge --auto-remove soapysdr-tools
sudo apt-get purge --auto-remove soapysdr*

this will delete all soapy then reinstall it again.

Thanks Ancer.
Kc7noa - I tried the apt-get on the package page and it got to close to the last line then turned up an error. I tried to clean it up with synaptic and things got worse.

Larry in El Paso

I used apt-get than synaptic heres good useful command for it.

1 Like

Thanks again Ancer, neat link. I bookmarked it.

Larry in El Paso

You are very welcome for me i was surprise that ubuntu is now is a lot better before 1st installed and work right away like a charm i was a opensuse person for years now ubuntu 73 VA6RBC.