Soapy error: setSampleRate() -- rate too high

Dear All,

I am using the latest Pothos version (August 13) on windows.

While using the LimeTxRxDemo with the LIMESDR, I get always this error:

[13:58:46.031000] SoapySDR: Estimated reference clock 0.0000 MHz

[13:58:46.031000] SoapySDR: Selected reference clock 30.720 MHz

[13:58:46.036000] SoapySDR: Device name: LimeSDR-USB

[13:58:46.036000] SoapySDR: Reference: 30.72 MHz

[13:58:46.036000] SoapySDR: Init LMS7002M(0)

[13:58:46.036000] SoapySDR: LMS7002M cache /.limesuite/LMS7002M_cache_values.db

[13:58:46.036000] SoapySDR: Ver=7, Rev=1, Mask=14

[13:58:46.064000] SoapySDR: LMS7002M calibration values caching Enable

[13:58:46.073000] SDRBlock: call setupDevice threw: Exception: SoapyLMS7::setSampleRate() – rate too high

The sample rate in the example is 1e6,

Even if I change it to another value like 100e3, I get the same error.

I also got this and added some debug info. It seems there is something funny with the gateware for channel 1 as i get
[INFO] SoapyLMS7::setSampleRate(Rx, 0, 10 MHz), CGEN=80 MHz, ADC=20 MHz, decim=2 [2]
[INFO] SoapyLMS7::setSampleRate(Tx, 0, 10 MHz), CGEN=80 MHz, DAC=20 MHz, interp=2 [2]
[INFO] SoapyLMS7::setSampleRate(Rx, 1, 10 MHz), CGEN=15,3605 MHz, ADC=1,03569 MHz, decim=0,103569 [1073741824]
when i change the lime driver to print what is going on.

I was able to “solve” this by forcing the LMS suite to use cached values. Maybe this also happens if the cache is bad.