Self_test fail?

I’m running the self_test using the instructions here:

I’m getting strange results in step 3.7. My fft view looks nothing like the documentation. Please see the screenshot below. I have a v1.2 board and have recently updated the firmware using the LimeSuite GUI.

Is this board OK?


@andrewback What do you make of this? If it’s something trivial, I’d love to get it sorted before tomorrow. I’ll be giving an SDR demo at our hackerspace before Dr. Tom Rondeau speaks!

Although, if there is a hardware issue, that would explain my troubles in receiving a simple FM broadcast.

Thanks much,

Hard to say what your problem is since you’ve not included any info except to tell us it doesn’t work.

I recall when running the sanity tests that I had to exit limesuitegui then start it again between tests. Did you try that?

What antenna and what software did you try for FM?

There are some discussions here about this using Gqrx.

@peter is this latest master? I think the recent calibration updates dont work on the older hardware revision. Can you try the stable branch of limesuite if that is the case (stable is based off of v17.02.1 tag with some extra fixes).

Hey @hTo137, thanks for the reply and sorry, this wasn’t supposed to be the post to address my troubles with receiving an FM broadcast. That’s over here:

I’ll continue over there.

I could be wrong, but I think this assumes that the problem is that I’m able to complete a successful test, but that the second time around it fails. This isn’t the case. I’m stuck with unexpected results on the loopback test (step 3.7), which of course doesn’t involve antennas.

Thanks @joshblum, I was using the binaries from the xenial PPA. I compiled the stable branch as you suggested. I get the same looking FFT view.

I will try to see what my 1.2 device looks like. Sadly I broke one of the baluns :frowning:

A few quick thoughts though

  1. I was worried about the master branch. The xenial PPA should be fine actually for the 1.2 board, theres only few minor changes on the stable branch.
  2. The self test ini file might be specific to the latest mask of the LMS7 RFIC, which is not on the 1.2 board. So while something like GQRX should work, the ini file could just have incompatible register settings.

Thanks @joshblum, that would be helpful to know if the self_test is compatible with the 1.2 rev.

I’ve been on a bit of an odyssey. I thought maybe that my issues with receiving had to do with interference, so I picked up an aluminum case from Luftek. I also got some antennas from Dangerous Prototypes. Somewhere before receiving the antennas, I lost my FX3 boot jumper. Now that I replaced that and upgraded my firmware, connecting with GQRX isn’t working with the settings I had been using. :frowning:

When I connect, nothing happens.

LimeUtil --find, LimeUtil --info, SoapySDRUtil --info, SoapySDRUtil --find=“driver=lime” all return expected results.

Hello @peter,

First of all, we do not support 1v2 version anymore. I do not have 1v2 version board hence can not try it, but will give some thoughts for you.
You have to upload img file (file name LimeSDR-USB_fx3_fw.img) to FX3 MCU from this link.
You have to upload FPGA gateware (file name LimeSDR-USB_lms7_trx_HW_1.2.rbf) from this link.
After this you will have the latest firmware and gateware for 1v2 board. Do not use automatic update feature, update it manually.

1 Like


Not to undermine your comments, but I did an automatic update of my V1.2 LimeSDR and it was updated without issue - ran fine. But I DO subscribe to your process on that (manual update).

73 de Marty, KN0CK

Thanks @Zack, for letting me know it’s unsupported. That’s totally reasonable. Yet, I wish there was some way for me to know if this board is worth investing any more time in.

I applied the manual updates and nothing has changed in terms of the FFT view in the self test. Nothing is happening when I connect in GQRX, trying previously working configs in either xenial or OSX.

@Zack, I just sent an email to that I cced you on. Thanks for reading!

Hello @martywittrock,

Yes, automatic update should work as well, I just want to be sure what is uploaded in this case. Hence suggested manual update with particular images.

1 Like

Hello @peter,

Sorry for this.
I’ve just uploaded the latest LimeSuiteGUI here, file name LimeSuiteGUI_20170425_70264c.exe . Could you double check if it is working, please.

Hello @peter,

Yes, I see, thanks. Let me see what we can do.
We are trying to sort out the issues for 1v2 board, will update you later.

@Zack, thanks very much!

Hi @Zack, I just tried version LimeSuiteGUI_20170425_70264c.exe, which now seems to be the most current build. Here’s a screenshot of the FFT view for the loopback test. It doesn’t seem to be significantly different. What you think?


Hi @peter,

Is there any chance to try a cooler fan?

Hey @Zack, I just tried the self test with the unit outside the case, with a computer fan blowing air at the unit. I get the same result. Is that sufficient, or did you have fan/heatsinks in mind?

FWIW, neither the LM7 chip or FGPA seem prohibitively hot to the touch during the test.


Hello @peter,

I got 1v2 board hence can check it. Go through the steps described bellow and let me know if you get the same result. The procedure is simple - it will receive a test signal from LMS7002M and show FFT:

  1. Download the latest compiled LimeSuiteGUI;
  2. Execute the software and connect to the board. FW/GW versions should be indicated at the bottom status bar as follows:
  3. Download and upload LMS7002M configuration ini file;
  4. Go to CLKGEN tab and press “Calculate” button;
  5. Go to menu Modules -> FFTviewer. FFT window appears;
  6. You should the this: