Problem with Lime-SDR flash/programming


I’m new to Lime, and have been having the following issue with my Lime-SDR - bear with me as I’m trying to be very descriptive and give all the details in the hopes someone can spot what I’m doing wrong…

When I start up the Lime Suite (after installing Porthos and the Lime SDR USB driver on a Windows 10 machine), and select the Lime USB device to connect to, it takes about 30 seconds to get a connection, and this comes with some errors in the console log:

In case the image does not load, the log file says -

WARNING: Gateware version mismatch!
Expected gateware version 2, revision 21
but found version 0, revision 0
Follow the FW and FPGA upgrade instructions
Or run update on the command line: LimeUtil --update

and then I receive about twenty errors that look like -

[06:22:59] ERROR: TransferPacket: Read failed (ret=0)

with the last line being -

[06:23:33] INFO: Connected Control Port LimeSDR-USB FW:4 HW:4 Protocol:1 GW:0.0 Ref Clk: -0.00 MHz

So here is the problem

After this, I am able to use both the Windows Powershell prompt and execute the “LimeUtil --update”, or can use the “Modules --> Programming” and AUTOMATIC setting to program the Lime-SDR. Both of these methods result in a “programming complete” without any errors.

However, upon re-cycling power/USB connection, I receive the same error - Gateware mismatch. I started trying this last night, and after dozens of attempts varying the approach (power cycle, no power cycle, leave USB connected, cycle connection, etc.) it worked.

I was able to perform the loopback test, and set the receiver for a receive test, and then powered the unit down for the night.

Unfortunately, when I restarted my unit this morning, it was back to receiving the errors and did not show the proper gateware being loaded. I once again have been trying to program the unit through the various methods (even tried the direct FPGA and FT3 loads through the programming module after locating the current gateware/firmware.)

The flash does not appear to program correctly (or hold the program), and now I can’t seem to even get it to program at all. What am I missing? The unit firmware has been updated since my purchase, but it seems like the gateware never loads properly.

Thanks in advance for any help,


Hi @kd6not,

Update the gateware using the latest LimeSuiteGUI. Gateware version should be 2.22.