Pothos MIMO enable not working?

Does anybody @joshblum ? know how to use 2 channels simultaneously in Pothos? I seem to have hit a brick wall with this and I’m thinking it might have something to do with:

Frontend map:Specify the mapping of stream channels to RF frontends. The format of the mapping is implementation-specific.

Here’s my block diagram:

Both periodograms display channel 0.
I can use channel B on it’s own and it receives on the correct antenna:

Please could we have a MIMO enable button? Pretty please? :sob:

I think its an issue of configuring the block for multiple channels. With the LimeSDR the pair of channels always comes aligned, so you need both channels to come out of one block. Does this help? https://github.com/pothosware/pothos-sdr/wiki/Tutorial#channels Let me know.

1 Like

Many thanks Josh - Yes this helps a great deal - I’ll give it a try tomorrow.

Not sure what’s going on here. Adjusting the frequency on one channel seems to affect the other channel and I wouldn’t expect that to happen! Is this something to do with the 2 channels being aligned?

Also, I don’t seem to be able to get the spectrogram or periodogram to scan more than 2 MHz on the x axis, even if I turn up the bandwidth to 50 MHz. :confused:

If anybody wants to check this out, the file is in the files section: Testing MIMO 01.pothos

I’ll point you at a answer to a question asked a while back and maybe the answer might shed some light on what is happening, as opposed to what you expect to be happening.

Thanks @mzs - I was aware of that limitation. I tried to do some more work on this project last night and the pothos software suddenly took an extreme disliking to my block diagrams, like it’s trying to tell me something. Now I’m reassembling it one block at a time to make sure everything is matched properly. Maybe it will cure the [quote=“TegwynTwmfatt, post:4, topic:1074”]
Adjusting the frequency on one channel seems to affect the other channel

I got my Pothos sketches up and running again this morning but still no progress :disappointed: Adjusting the frequency on channel B only affects channel A whilst in MIMO mode. The frequencies are close enough together and I can’t see any fault in the block logic. I guess I’ll need to recreate the sketch in GNU radio and see if it works there.


Ok … @joshblum … Here’s an update:

Channel 0 works fine on it’s own
Channel 1 works fine on it’s own
Channel 0 + Channel 1, with less than 60MHz between them, does not seem to work with Pothos or GNU radio.

Therefore I suspect the Soapy driver. Which driver handles MIMO?
Thank you!

OK … I’ve thought of a workaround
… Use Pothos and Limesuite interface simultaneously
… there’s a nice big ‘Enable MIMO’ button to press.
… Question is … Will it destroy my PC / LimeSDR ?
Maybe I should create a poll and we could have a vote?

1 Like

My guess is that whichever of the two you start second will fail to open the device.

@andrewback … I tried it … and it works! YAAAAYYYYYYYYYY I can adjust the PGA gain on both channels independently on the Limesuite interface, but not surprisingly, it only shows changes on one of the spectrometers in Pothos. Another pointer to faulty/missing driver?

Another 2 quick questions, including at least 1 possibly stupid one: In Pothos we have ‘activate topology’, which ‘executes’ the block diagram:

1.Can we access the file that Pothos creates like we can see the python file in GNU radio?
2.Does Limesuite have a button similar to ‘Activate Topology’ ?
3.Does ‘Activate Topology’ have a register and if not, how does it work?

I’m a bit confused here!

Hm, wouldn’t have expected it to be happy with two different pieces of software opening the device at the same time. Pothos questions are best directed to @joshblum.

@andrewback … I don’t think Josh visits here very often :disappointed: … But if you do happen to bump into him, please could you ask him to have a look at the 3 questions above? Thank you!

That is what I have seen.

Maybe you select ‘Enable MIMO’ then GUI->Chip then run Pothos.
GUI->Chip == ‘Activate Topology’ ???

Pothos can save as json but I don’t know about any code or compiled output.

Both programs ran the device simultaneously - most unexpected!

This could be correct and it’s worth experimenting with unless someone with the relevant experience can point me in the right direction?

Inconceivable! But good to know it worked. I have tried to run multiple apps at once and always found that the first app maintains control over the USB3 bus. Maybe you had both cables plugged in???

I think you’re in the driver’s seat. :blue_car:

Yes both cables were plugged in, but I don’t see what diff that would make?

I did load the latest gateware, v2.7 from memory.

Driver’s seat … I suppose so! :worried:

The double cable thing is just my guess, that, that is what made it possible for two apps to have access to the LimeSDR at the same time.


In case you are talking about double USB cable delivered with LimeSDR, the
second thin cable is only +5V DC power distribution over two USB 3 PC sockets.
I am using other high end 1 m USB 3 single cable without any trouble…

1 Like

Makes sense to me.