PopthosSDR error indicating Python error

#1

Hi Guys,
Just got PothosSDR up to run and I have Python installed (2.7.13 64 bit) and come up with an error
that it is a Python problem along with a gateware problem. I was following the Pothos SDR environment tutorial
to try and get this setup correctly. Exactly which python version is used and how do you upgrade gateware?

Thanks!

Paul

[21:34:31.454010] PothosGui.MainWindow: Welcome to Pothos v0.5.1-PothosSDR-2017.08.13-vc14-x64
[21:34:31.594638] PothosGui.MainWindow: Initialization complete
[21:36:07.956000] Pothos.PluginLoader.load: Plugin Module Error: Pothos::PluginModule(C:\Program Files\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll): failed safe load
[21:36:08.013000] : Win32; Microsoft Visual C++ version 14.0; Boost_106300; UHD_003.010.002.000-0-gbd6e21dc
[21:37:15.571000] SoapySDR: Make connection: ‘USB 3.0 (LimeSDR-USB) [USB] 9061C02D12F13’
[21:37:15.587000] SoapySDR ⇒
Gateware version mismatch!
Expected gateware version 2, revision 8
But found version 2, revision 6
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

[21:37:15.759000] SoapySDR: Estimated reference clock 30.7196 MHz
[21:37:15.759000] SoapySDR: Selected reference clock 30.720 MHz
[21:37:15.759000] SoapySDR: Device name: LimeSDR-USB
[21:37:15.759000] SoapySDR: Reference: 30.72 MHz
[21:37:15.759000] SoapySDR: Init LMS7002M(0)
[21:37:15.759000] SoapySDR: LMS7002M cache C:\Users\Paul’s-i7-Torbo/.limesuite/LMS7002M_cache_values.db
[21:37:15.759000] SoapySDR: Ver=7, Rev=1, Mask=1
[21:37:15.790000] SoapySDR: LMS7002M calibration values caching Enable
[21:37:16.118000] SoapySDR: Rx Filter calibrated from cache
[21:37:16.118000] SoapySDR: Tx Filter calibrated from cache
[21:37:16.149000] SoapySDR: Rx Filter calibrated from cache
[21:37:16.149000] SoapySDR: Tx Filter calibrated from cache
[21:40:16.337000] : Proxy server: No active connections - terminating
[21:40:35.221000] Pothos.PluginLoader.load: Plugin Module Error: Pothos::PluginModule(C:\Program Files\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll): failed safe load
[21:40:35.299000] : Win32; Microsoft Visual C++ version 14.0; Boost_106300; UHD_003.010.002.000-0-gbd6e21dc
[21:40:53.730000] SoapySDR: Make connection: ‘USB 3.0 (LimeSDR-USB) [USB] 9061C02D12F13’
[21:40:53.754000] SoapySDR ⇒
Gateware version mismatch!
Expected gateware version 2, revision 8
But found version 2, revision 6
Follow the FW and FPGA upgrade instructions:
http://wiki.myriadrf.org/Lime_Suite#Flashing_images
Or run update on the command line: LimeUtil --update

[21:40:53.918000] SoapySDR: Estimated reference clock 30.7196 MHz
[21:40:53.918000] SoapySDR: Selected reference clock 30.720 MHz
[21:40:53.918000] SoapySDR: Device name: LimeSDR-USB
[21:40:53.918000] SoapySDR: Reference: 30.72 MHz
[21:40:53.918000] SoapySDR: Init LMS7002M(0)
[21:40:53.918000] SoapySDR: LMS7002M cache C:\Users\Paul’s-i7-Torbo/.limesuite/LMS7002M_cache_values.db
[21:40:53.918000] SoapySDR: Ver=7, Rev=1, Mask=1
[21:40:53.949000] SoapySDR: LMS7002M calibration values caching Enable
[21:40:54.261000] SoapySDR: Rx Filter calibrated from cache
[21:40:54.261000] SoapySDR: Tx Filter calibrated from cache
[21:40:54.293000] SoapySDR: Rx Filter calibrated from cache
[21:40:54.293000] SoapySDR: Tx Filter calibrated from cache
[21:40:54.590000] ::1: SetFrequency using cache values vco:0, csw:10
[21:41:44.846000] ::1: SetFrequency using cache values vco:0, csw:10
[21:41:45.583000] ::1: SetFrequency using cache values vco:0, csw:10
[21:41:46.142000] ::1: SetFrequency using cache values vco:0, csw:10
[21:41:56.846000] ::1: SetFrequency using cache values vco:1, csw:141
[21:44:06.781000] ::1: SetFrequency using cache values vco:0, csw:10
[21:44:09.907000] ::1: SetFrequency using cache values vco:1, csw:122
[21:45:52.174768] default: libpng warning: iCCP: known incorrect sRGB profile
[21:46:03.847342] default: libpng warning: iCCP: known incorrect sRGB profile
[21:46:43.408281] default: libpng warning: iCCP: known incorrect sRGB profile
[21:47:49.861652] default: libpng warning: iCCP: known incorrect sRGB profile
[21:47:52.862140] default: libpng warning: iCCP: known incorrect sRGB profile
[21:47:52.862140] default: libpng warning: iCCP: known incorrect sRGB profile
[21:47:54.860491] default: libpng warning: iCCP: known incorrect sRGB profile
[21:47:54.860491] default: libpng warning: iCCP: known incorrect sRGB

#2

This is how I did it. What operating system?

#3

Axeman,
I am using WIndows 10. I tried to update using the same LimeSDR utility but I think that since it isn’t recognizing that there is Python already on the system “[21:36:07.956000] Pothos.PluginLoader.load: Plugin Module Error: Pothos::PluginModule(C:\Program Files\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll)”. I thought that it wouldn’t as Python is a great scripting language. Anyway I am stumped right now and hopefully I will figure something out or be lucky enough to read of a solution! I truly appreciate your answering but I think it’s like hitting a moving target in the dark at this moment.

73,
Paul
AI6PC

#4

I use Linux but it has that same library with an .so extension. It came from the Pothos install automatically.
“Failed safe load?” Maybe a security setting? I have never got my Windows installation working but it is because I haven’t tried.
It seems like it is working anyway up to the point of displaying something and then libpng is gagging.

#5

I will try and see what I can find. According to the internet an .so and .dll (dynamic linked library) are supposedly
OK with windows so I will ask around. Interestingly enough (according to file.org) their use is mostly to do with
C and C++!

Thanks again!

#6

Hi pjb789:

I’ve got the same issue as you mentioned before,Plugin Module Error: Pothos::PluginModule(E:\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll): failed safe load,
Have you already resolve it?

#7

Same here, everyone. Fresh Pothos install (2017.11.1 vc14 x64) on Windows 10, and when running the LimeSDR Workshop files cloned straight off of the github I get the following error when initializing.

[04:33:20.187000] Pothos.PluginLoader.load: Plugin Module Error: Pothos::PluginModule(C:\Program Files\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll): failed safe load

#8

I haven’t been able to use Pothos in a while now. I have quit trying. Maybe I will try to get this nailed down as I will have some time.

#9

I don’t know about Windows but I found out the source directory has changed at Github to PothosCore. The executable is called PothosFlow.
I have deleted my old /pothos instalation and PothosGui and now it works again.

#10

I have the same problem here (Windows7 64bit):
Pothos.PluginLoader.load: Plugin Module Error: Pothos::PluginModule(C:\Program Files\PothosSDR\lib\Pothos\modules0.5\proxy\environment\PythonSupport.dll): failed safe load

#12

It’s not a solution but here is the code that throws the error. I am suspecting it;s a 64/32 bit issue, and we are all on 64. Is anyone having the problem on 32 bit Windows?

#13

Please note that there is a discussion group for Pothos where you may get faster answers to such questions:

https://groups.google.com/forum/#!forum/pothos-users

#14

Thanks @andrewback. I found some guidance there and solved it.

SOLUTION: Install Python 3.6 64 bit and make sure it is in the path.
https://groups.google.com/forum/#!searchin/pothos-users/failed$20safe$20load|sort:date/pothos-users/380EAoIj7AM/yKturFOmDQAJ

1 Like
#15

In such security issues should be maintained by all the users to access safely. If they need any suggestions given by how to remove a hacker from my phone which guides them.