OpenAirInterface configuration

#36

Hello Joey, I am facing the same problem as you (the RIV_max issue). I didn’t get how did you solve it. Was it the configuration file or you changed the PC? Do you know the main cause of this problem?

Please help me to get through it.

Thanks in advance!

#37

Hi Yaya,

The rf-config file change from comment 14 above fixed that issue for us.

Use

--rf-config-file = LimeSDR_above_1p8GHz.ini

instead of

--rf-config-file = LimeSDR_above_1p8GHz**_1v4**.ini
1 Like
#38

Thanks for the clarification. I will do that and see how it goes. I will also follow your advice and try to update the EPC side since it is too fragile as is.

#39

FYI, we have found latest CN (EPC) develop branch is much more stable for us. Note that fixed-broadband branch was renamed to develop in the last week. So I suggest a fresh checkout if you haven’t recently.

Also, for lime users (i.e. this forum) the eNB code on develop has been updated and now is performing stably for us. So we are no longer using calib-LimeSDR, we have switched to develop there too.

#40

Hi,

Joey and I have been using this wiring (TX1_2 and RX1_H) for a couple of months and it has been working okay.

I am experimenting with the LimeSuite API (LMS_* functions) this week and found an interesting thing: lte-softmodem is listening to RX1_L rather than RX1_H. That’s what LMS_GetAntenna says (returns 2, which is the index to RX1_L).

I moved the uplink antenna to RX1_L (the second port in the bottom row), and SpeedTest upload went up to about 8 Mbps from 1 Mbps. Disconnecting the antenna still gets about 1 Mbps, so basically we have lived without an unlink antenna for two months (!)

ARCH/LMSSDR/…/lms_lib.cpp has a commented line that forces to use RX1_H, but uncommenting it crashes lte-softmodem.

Has anyone seen this, or is this just happening to us?

Thanks,

–tak

#41

I have some old SpeedTest results with fast upload results, so I’m wondering if this RX1_L/H confusion could be from the 2.8 firmware (02-Apr-2017). I do remember that I used to run the 2.6 firmware.

–tak

Does lms_lib.cpp for OAI support selecting the external clock on the LimeSDR?
#42

Another topic…

It seems that the lms_lib.cpp doesn’t support MIMO yet. Is it correct – any plan/development for supporting it?

Thank you,

–tak

#43

HI, just working on a project and hit this same error. Has this been resolved within the apt install approach ? Also wondering where the mentioned detailed guide can be found for LMSSDR for openairinterface .

#44

Hi,
I have tried to follow the instructions that Andrewback has suggested. Also, Joey’s comments on the cmake_targets/tools/fix_asn1 patch file was also helpful. But the compilation fails for the same error as @Practicing and @brian have mentioned.

'CMakeFiles/oai_lmssdrdevif.dir/openairinterface5g/targets/ARCH/LMSSDR/USERSPACE/LIB/lms_lib.cpp.o
/openairinterface5g/targets/ARCH/LMSSDR/USERSPACE/LIB/lms_lib.cpp:39:28:
fatal error: lime/LimeSuite.h: No such file or directory
#include <lime/LimeSuite.h>
^
compilation terminated.
make[3]: *** ’

Any suggestion on how to resolve it?

Thanks,
Moshiur

#45

The issue you have stems from using precompiled Lime drives via “sudo apt-get install limesuite”. This precompiled version lacks file headers for some reason so the automated OAI builder can find the files. remove the files with “sudo apt-get remove application” then reinstall the files from source. The new files should have headers and OAI should build

#46

Thank you Matt. Yes, we have resolved the issue by compiling the LMSSDR from source.

1 Like
#47

If using packages and building software that links with Lime Suite, also install: liblimesuite and liblimesuite-dev .

#48

Hi ,
i build and run eNB with the help of this topic and this blog post : https://open-cells.com/index.php/2017/08/22/all-in-one-openairinterface-august-22nd/

I change tx_gain in file enb.band7.tm1.50PRB.lmssdr.conf and every thing seems work properly but my phone can’t see the network .
i use LTE sim for local operator , and my phone support LTE band 7 .

what is the problem , must i use an especial sim ??

#49

Someone on this thread with experience may be able to comment, but failing which I’d suggest posting to the OpenAirInterface community.

#50

Experiencing the same problem now, did you find a solution?

I am using a PCTEL scanner device so I am not bound to having a SIM. The scanner detects the raise in energy but is unable to decode anything on that channel.

#51

Hi , first of all make sure your phone support that LTE band .
My problem solved , i used MNC and MCC code exactly the same as my sim card operator , i changed that to some thing different and it works .
Now i can see the network but i can’t register on that , which is normal . Unlike GSM , registration on LTE network need blank LTE sim card , and sim card writer for writing some parameters in sim card .

#52

I got closer to a working setup by increasing tx gain and the scanner sometimes decodes RSRP, RSRP and CINR but it also appears to loose synch to the cell. Over a period of 30 seconds I get quite good measurements part of the time, bad measurements part of the time and no measurements at all part of the time. Over the course of one hour it was only able to succesfully receive and decode one MIB. A UE can sometimes detect the NW, but without a proper SIM it cannot of course register on the found NW/cell. The scanner has no problems with the live commercial networks and their cells.

The PC has p_states, c_states, hyperthreading, etc disabled and CPU clock is stable. Running a low-latency kernel on a quite capable CPU. I don’t get any “L” printed in the console

#53

Hi,

@ashtum did you have any luck with running the OAI ?

I am also using the same guide for my setup. It is not clear to me that everything is explained with enb band 7 which is 2680MHz but in the .ini files (\targets\ARCH\LMSSDR) Tx set to 1850MHz and Rx set to 1755MHz. I checked the .ini files by loading into LimeSuiteGUI.

It is not clear to me what is the relation between enb.conf files and .ini files and why the DL freq. is different ?

Any help would be great.

Regards,
Ubaid

#54

Hi,
Yes , finally i could see the network in my phone .
Freq setting in .conf file is just matter . my problem was that i used MNC and MCC like my LTE sim card which make my LTE BTS name invisible in search list . When i change MNC and MCC to some thing different it’s name appear in found networks .
Unfortunately i have removed files but as far as i can remember i did’t change any settings except tx_gain .

#55

Reading available sources I am bit confused regarding status of OpenAirInterface
functionality on LimeSDR:…

Blockquote http://www.openairinterface.org/?news=openairinterface-works-with-limesdr

Blockquote https://open-cells.com/index.php/2017/08/22/all-in-one-openairinterface-august-22nd/

Blockquote https://open-cells.com/index.php/2017/05/10/limesdr-installation/

@Laurent Can you please let us know, what is actual status ?
BRG
Djani