Open Air Interface with LimeSDR

Hi All,

I’ve been attempting to run OAI version 0.6 on LimeSDR with Ubuntu 14.04 LTS. I’ve been using this as a guide:

However when I run this command to compile and run:

./target/bin/lte-softmodem.Rel14 -O enb.band7.tm1.25PRB.lmssdr.conf

I get an error stating:

Assertion (0) failed!
In enb_config_init() /home/ja479/openairinterface5g/openair2/ENB_APP/enb_config.c:721
Failed to parse eNB configuration file enb.band7.tm1.25PRB.lmssdr.conf!
There doesn’t seem to be any log files detailing why this happening either. I am very new to OAI so I do not have a clue on why this is happening?



I don’t have any experience with OAI as yet, so can’t help, but others on here have.

@IgnasJ, not sure if you have any suggestions?

are you sure that path for eNB configuration file (enb.band7.tm1.25PRB.lmssdr.conf) is correct? For me it looks like eNB (lte-softmodem) cannot find it.

Its been awhile since I tried runing OAI, but looking at my notes, the launch command that used to work for me is:
sudo ./targets/bin/lte-softmodem.Rel14 -O targets/PROJECTS/GENERIC-LTE-EPC/CONF/enb.band7.tm1.25PRB.lmssdr.conf --rf-config-file ./targets/ARCH/LMSSDR/LimeSDR_above_1p8GHz_1v4.ini

Thank you! That command seemed to work however it seems to have uncovered something else relating to the file “openairinterface5g/openair3/UDP/udp_eNB_task.c”
It states:
UDP: Failed to bind socket: (Cannot assign requested address:99) address port 2152
How would I go about changing the IP address?

IP address is set in eNB configuration file (targets/PROJECTS/GENERIC-LTE-EPC/CONF/enb.band7.tm1.25PRB.lmssdr.conf)

eNB tries to use IP set by ‘ENB_IPV4_ADDRESS_FOR_S1_MME’ and ‘ENB_IPV4_ADDRESS_FOR_S1U’ settings. It should be IP address of machine that eNB is running on.

‘mme_ip_address’ is the IP of MME/EPC that eNB tries to connect to (it can be different machine).

During my testing, I ran eNB and MME on the same machine and both of them were sitting on localhost.

So all three IP addresses should be the same as the host PC?

MME and eNB cannot use same IP. I probably was not clear, I meant to say that both of them were on ‘Local Loopback’ interface.

Here is an example configuration from eNB file that I used:.

////////// MME parameters:
mme_ip_address      = ( { ipv4       = "";
                          ipv6       = "192:168:30::17";
                          active     = "yes";
                          preference = "ipv4";

    ENB_INTERFACE_NAME_FOR_S1_MME            = "lo";
    ENB_IPV4_ADDRESS_FOR_S1_MME              = "";

    ENB_INTERFACE_NAME_FOR_S1U               = "lo";
    ENB_IPV4_ADDRESS_FOR_S1U                 = "";
    ENB_PORT_FOR_S1U                         = 2152; # Spec 2152