OAI and LimeSDR-Mini


#43

I have no idea what to do of the mcc and mnc if i use the mcc and mnc in our country, the configuration of telma is mcc=646, mnc=04 and apn="internet’. i 'm afraid it’s has any interference! is possible to have a couple correct mcc-mnc-apn in your countrie like i’m giving you !?


#44

But with my Limesdr-Mini, i run OpenBTS with test network 001-01, my phone connect correctly using pisword lte usim. Like the authentication with pisword lte usim is milenage the openbts-umts has always failure connection but it’s also authenticate correctly with ‘magic sim’ !!!


#45

@dast don’t try MCC/MNC of your country but try another one like SFR in France. For the APN config you follow your oai_db “pdn informations”, changing PLMN require updating your database with your new informations.


#46

did you manage to connect to your enodeb?


#47

I succeeded, just 2 times. It connects for almost 1 minute and disconnect. Right now I try to troubleshoot HSS part (authentication, MCC/MNC) if I don’t succeed --> I will Try another steps :

  • Change UE.
  • Try distributed Topology : EPC in host 1, eNodeB in host2.
  • Duplexer LTE Band 7.(its expensive solution but it helps a lot to eliminate interference between Tx and RX).

If you have any other ideas it would be great.


#48

what do you mean about changing plmn in my database ? did you refer about the table users ?


#49

My idea is instead of using duplexer, i’m waiting for having my boost antenna with rx and tx like this : LF - ANT4G01 4G LTE TS9 Brancher 49dBi MIMO Antenne Signal . In this link https://fr.gearbest.com/networking-communication/pp_227644.html?wid=1433363&fbclid=IwAR3DC9m9zRAhpZE_eGAwiuweYrHecCTrRB56s74P2pChzj_W5Qg_qb3PXFM#goodsDetail the sma is not provided but you refer on aliexpress or ebay you could also find it!how cost is the duplexer now?


#50

Yes, when you change MCC/MNC configuration in eNB and MME, also your IMSIs users must start with MCC/MNC numbers that you use, for example SFR MCC/MNC = 208/10 you can create user with IMSI = 208100100001108. PDN include information that you need for APN .


#51

For the duplexer cost, until now I found 2 offers :

  1. The first one was recommended by @cswiger in this post : OAI Progress - next error. It’s cheap but they didn’t replied to my e-mails regarding checkout and shipping method.

  2. Duplexer made of cavity filters I think much better but more expensive : https://open-cells.com/index.php/opencellsband7duplexer/


#52

if it’s not so perturbing you, is it possible to have a full log (hss, mme, spgw and enodeB) when you phone logged to your OAI and also a full log when it has error “the error Failed to find ue context associated with eNB ue s1ap id”. I would like to compare with mine !


#53

@dast here a link : https://www.dropbox.com/sh/462hnb8jl10fzn4/AABxo71pAr50_lTR3zRk7Lpwa?dl=0 where you can find my full log for (hss,spgw, eNodeB and even tcp_dump_gtp0 ) but unfortunately didn’t save a log for MME.


#54

And for better undersatnding my testbed set , First time I ran OAI on in Inspiron-3542 wich has i3-4th gen cpu and USB 3.0 not running properly , so I succedded to connect 2 or 3 times to the eNB but didn’t last for long time I think 'cause of timing problem (UE-eNB), I concluded this from this debug : https://www.dropbox.com/s/0ab7p5dp28it9go/eNB.txt?dl=0. here also you can see in the scope that am connected and reach 120 kb/s :

than I tried to solve problem of timing and latency caused by i3 PC by running OAI in another hardware, “[PHY][I]rx_rf: rfdevice timing drift of” error were solved but didn’t succeded to connect with eNB.


#55

so the error drifting for the hardware more powerful is not resolve! i hear that the LLL problem is due to of lowlatancy (cor i3 doesn’t support low latancy for lte). The error drifting is may be due to the port of the computer ?


#56

An i3 CPU can support low latency, but you will need to disable C states and SpeedStep in the BIOS and in the kernel startup parameters (for the enodeb, the core does not need low latency). However this will not help the fact that an i3 CPU might be not powerful enough. AVX support is also helping quite a bit.


#57

@dast The error drifting were solved when I changed the host PC. it’s most probably due to USB port like you said to me before.So with the new I5-4th gen PC I solved the problem of “error drifting …” but didn’t succeed to connect to eNB, some times I got something on the scope when I try to register the phone I got your same error " error Failed to find ue context associated with eNB ue s1ap id”


#58

@dchard, Yeah I tried your solution, I installed low latency ubuntu image, C state disables and also hyperthreading and all the stuff described in this link : https://gitlab.eurecom.fr/oai/openairinterface5g/wikis/OpenAirKernelMainSetup

I can see my OAI eNB but fails to register.


#59

Can you send me your enb config?

Latest develop branch seems to have lost the limesdr related config files, as there were quite a big change in the code at some point. I am trying to figure out how to modify/expand an usrpb based file, but no luck so far…


#60

when do it i alway have LLL LLLL LLL and the enodeB not run for my cpu core i3. lenovo.


#61

On the site of mobibrw for the oai with limesdr v4, he use this link :
https://item.taobao.com/item.htm?id=558995437526&fbclid=IwAR3FlQaMsKShC0EXAK5UkCqJVtmLXaocstrP4JZnkFyLLncwxzCmxSogp6Y for the duplexer


#62

@dasthttps://item.taobao.com/item.htm?id=558995437526&fbclid=IwAR3FlQaMsKShC0EXAK5UkCqJVtmLXaocstrP4JZnkFyLLncwxzCmxSogp6Y for the duplexer” are you sure LTE Band 7 ??