OAI and LimeSDR-Mini


#23

tutorial for limesdrmini with oai here https://bastienbaranoff.wordpress.com/2018/10/23/openairinterface-4g-lte-with-limesdr_mini/


#24

Thank you @bastienbaranoff & @cswiger for your great tutorials and tips they were very helpful. Now am running OAI with my limesdr-mini and unfortunately I didn’t manage to get a suitable commercial phone (UE) with the programmed USIM yet, at the meanwhile I got this output :

“[PHY][I]rx_rf: rfdevice timing drift of 2720 samples (ts_off 26720)” after the “L”, I wanted to know if I am on the right way ? Kindly to find a full ltesoftmodem log in this link : https://www.dropbox.com/s/34pj60gqztpvm9y/ltesoftmodem_log.txt?dl=0&fbclid=IwAR0LcMKuu368Ir3jI64H1NnFN29uAjEdMsmieOpPRa-TvEZutCIQCPdRB80


#25

when you have the problem “rf device timing drift” it’s also error coming on the port:

  • may be you libusb is not installing correctly
  • may be you didn’t use usb 3.0
  • may be you use anormal usb 3.0, if the computer has other port usb3.0, try with it

#26

Yeah @dast I tried your suggestions and I’ve noticed that when I plug my limesdr-mini and run ltesoftmodem, it is directly driven to USB 2.0 even-though my physical usb port is 3.0, but when I restart ltesoftmodem second time it will be driven to USB 3.0 but am always getting “rf device timing drift” . I tried different ports on my laptops but no use, one more thing I’ve installed libusb using apt install libusb-1.0-0-dev. I checked it :
root@oai-Aspire-V3-575T:~# dpkg -l libusb-1.0*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
++±=============================-===================-===================-================================================================
ii libusb-1.0-0:amd64 2:1.0.20-1 amd64 userspace USB programming library
ii libusb-1.0-0-dbg:amd64 2:1.0.20-1 amd64 userspace USB programming library development files
ii libusb-1.0-0-dev:amd64 2:1.0.20-1 amd64 userspace USB programming library development files
ii libusb-1.0-doc 2:1.0.20-1 all documentation for userspace USB programming


#27

“[PHY][I]rx_rf: rfdevice timing drift of …" problem is so detrimental for the ltesoftmodem performances i.e : it will not let the UE see the eNB ? or has relation with DL throughput ?


#28

I am using Samsung galaxy S8+ trying to scan OAI enodeB deployed on my lime-mini, LTE band 7 locked using hidden network functions :

:frowning_face: unfortunately I started manual network resarch but didn’t detect anything . Please any idea about the problem ??

Note : I still having this error “[PHY][I]rx_rf: rfdevice timing drift of …" in the ltesoftmodem terminal, anotherthing to mention : I am not using programmed USIM card yet.

Help please.


#29

Hi @dast, I’ve solved “rf device timing drift” problem by changing my PC host so it was problem of hardware. I launched a scan for my eNB and my phone was able to see the nework 208/92. Now I am facing another problem , my phone is not able to register. Some times I got some signal on the Scope but failed to register.

Any help please regarding “Registering issue !!!” ???

Sim card used : Piswords Blank LTE USIM bought from Aliexpress programmed using personalize tool.
Phone used : Oppo R7s.


#30

i’m also fascinating to this problem ! maybe comment on this site web could help you : https://www.mobibrw.com/2018/10729/comment-page-1#comment-3451


#31

Mine also see the network but can’t access it! i use the same card ! pisword!!!when i test openbts-umts for example, when my simcard inserted on the phone is for the operator ! i see the network 001-01 (3g) ! when i insert the pisword card i can’t see the network!!! i don’t know what is the real problem of the lte-sim of the pisword!


#32

@dast What is your mobile phone model, and are you using LTE Band 7 duplexer ?


#33

my phone see the network for the 4g!!! but now i try to test the usim with openbts-umts. what kind of device and software did you use for programming the usim? me i use https://fr.aliexpress.com/item/LTE-FDD-WCDMA-CCID-SIM-USIM-4G-Secure-Card-Reader-writer-tool-cloner-programmer-clone-copy/32811023157.html?spm=2114.06010108.3.255.VkkYOL&ws_ab_test=searchweb0_0%2Csearchweb201602_5_10152_10065_10151_10068_5010019_10136_10137_10157_10060_10138_10155_10062_10156_437_10154_10056_10055_10054_10059_303_100031_10099_10103_10102_10096_10147_10052_10053_10107_10050_10142_10051_5190019_10084_10083_10080_10082_10081_10110_519_10111_10112_10113_10114_10179_10181_10183_10182_10185_10078_10079_10073_10123_142%2Csearchweb201603_9%2CppcSwitch_5&btsid=f3bb42fc-5ea4-48f7-a215-dc8277662c9c&algo_expid=26c514e3-8de7-46ba-b403-2eea71abe6df-35&algo_pvid=26c514e3-8de7-46ba-b403-2eea71abe6df&fbclid=IwAR2zYF3OVBPvlN3KxRp4Mkcx8Px4GTq25UnLtDGi-kg-YXjXdXGoFb0CwCc and the software http://www.mobibrw.com/wp-content/uploads/2018/03/GRSIMWrite-3.10.zip because the usim reader writter doesn’t have software for writting ki, op, msisdn and imsi by default! or what kind of software did you use ?


#34

I use the same the same tool “Piswords+GRSIMWrite-3.10” following this tutorial : https://www.mobibrw.com/2018/10729/comment-page-1

I found in some mailing-list of openairinterface that it can be problem coming from the used phone, what is your phone model ?


#35

I use samsung S5 . But i see the network! the problem is that i can’t access to it. My problem is not due to the phone, it’s due to the configuration


#36

@dast I found in an official wiki of openairinterface that some phones bought from a certain carrier. They have a wrapper that will block other networks, for example OAI. Here is another solution, https://lists.eurecom.fr/sympa/arc/openair5g-user/2016-06/msg00076.html

But this solution has high risk on the mobile ROM and need some knowledge about rooting and flashing.


#37

So we should name our network with the corresponding list of mcc, mnc !!! it’s the easy way to do it


#38

I would like to be sure if the phone send attachrequest to the OAI, did you have any idea for log trace to have this ?


#39

Well you can notice something in the debug output of lte-softmodem.Rel14 and ./run_hss .Did you tried to change another MCC/MNC,other than the default of Eurecom 208/92 if so what did you get ?


#40

I am trying to use my limesdr-mini with latest OAI develop branch. The software compiles just fine, the eNB app starts, the limsesdr mini looks like it is transmitting (green LED), but the RF output is completely silent. During the startup of the eNB app, I can see some RF activity, but thats it.

Can someone please share a working eNB config file for OAI?


#41

i have now the error : “Failed to find ue context associated with eNB ue s1ap id: 0” . Bastien say that , we could resolve it by : " by putting the mobile touching the antenna" ; and he alwaays says thar "The main problem was the power of the antenna i shall put the UE
close to the antenna with even touch the antenna… And my rx and tx gain
was at the max but it works for association and download
"


#42

@dast I have your same problem “Failed to find ue context associated with eNB ue s1ap id: 0”, What did you get when you changed PLMN (MCC/MNC) + oai_db update ??